How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Steve Your Own Question
Steve, Motorcycle Mechanic
Category: Motorcycle
Satisfied Customers: 6816
Experience:  30+ yrs. experience, MMI, HD technician, HD early, engine rebuild/performance, bike builder, kit bike program manager, CCI 2001-2004
Type Your Motorcycle Question Here...
Steve is online now
A new question is answered every 9 seconds

I have a 2014 Street Glide I have a electrical issue. When

Customer Question

I have a 2014 Street Glide I have a electrical issue. When I turn the ignition on at first the running lights flash on and off immediately . The front turn signals do not light up. The brake lights are on and the running light below the license plate does not light up. When I shut the ignition off a few seconds later all the lights will flash a couple times so I know all the bulbs are working. Any ideas of what the problem could be?
Submitted: 6 months ago.
Category: Motorcycle
Expert:  Steve replied 6 months ago.
it sounds like your security system is armed.- the first thing I would try is a new battery in your security FOB.- another option is to manually disarm the system with your security PIN code and the procedure on the wallet card in the back of your owners manual.let me know if you need more help.Steve