How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Tim's Auto Repair Your Own Question
Tim's Auto Repair
Tim's Auto Repair, mechanic
Category: Motorcycle
Satisfied Customers: 15486
Experience:  Have owned a repair shop for 25 yrs.
14541291
Type Your Motorcycle Question Here...
Tim's Auto Repair is online now
A new question is answered every 9 seconds

I have a Kymco sentro 50 scooter problem, it starts, runs

Customer Question

I have a Kymco sentro 50 scooter problem, it starts, runs well has acceleration but will go about 20 mph but will not rev up seems to bog and lean out, have so far replaced carb, and spark plug, compression test shows 170, but vacuum is low 7 in/mg drops to zero when i blip throttle, cam chain timing marks line up at tDC are OK. manifold to carb holds 10 psi no leaks.
Submitted: 8 months ago.
Category: Motorcycle
Expert:  Tim's Auto Repair replied 8 months ago.
Hi, My name is ***** ***** for the delay.I will do my best to assist youit would seem it is running out of fuel..make sure the filter isnt clogged,,if the filter is fine,then the problem may be the vacuum fuel pump
Expert:  Tim's Auto Repair replied 8 months ago.
i have seen the cdi box cause a similer problem by throwing the ignition out of time just a little..but,it does seem to be fuel problem
Customer: replied 8 months ago.
I have removed the gas line at carb, it flows nicely, if i partially block the carb opening to chock it it will rev higher, on one of the carbs i also tried a larger main jet , with slight improvement, but can you explain the low vacuum?
Expert:  Tim's Auto Repair replied 8 months ago.
yes..anything will have a low vacuum when you open the throttle...all the vacuum is lost through the carb butterfly..this is normal
Expert:  Tim's Auto Repair replied 8 months ago.
if gas is going to the cab well..then the problem may be the cdithanks
Customer: replied 8 months ago.
what about the low vacuum at idle it only 7 , should i have at least 15 IN/mg ? will the CDI cause this ?
Expert:  Tim's Auto Repair replied 8 months ago.
the vaciim seems to be ok..again with it not running right and when it needs more throttle the vacuum will drop
Customer: replied 8 months ago.
The vacuum is only 7 inches should it not be 20 at an idle? and again would the CDI cause that much of a vacuum drop and therefore the lean condition. i have also checked that the muffler is not plugged. any other possibilities, before i order a CDI ?
Expert:  Tim's Auto Repair replied 8 months ago.
the only other possibility that i can think of,is it would have had to jump time,,but,,i would doubt that.