How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Steve Your Own Question
Steve, Motorcycle Mechanic
Category: Motorcycle
Satisfied Customers: 6816
Experience:  30+ yrs. experience, MMI, HD technician, HD early, engine rebuild/performance, bike builder, kit bike program manager, CCI 2001-2004
Type Your Motorcycle Question Here...
Steve is online now
A new question is answered every 9 seconds

My 1974 ironhead motor has been completely rebuilt . when we

Customer Question

my 1974 ironhead motor has been completely rebuilt . when we start the engine it runs fine with good oil pressure after a short ride when engine warms up we loose oil pressure and oil stops flowing to the cylinder heads and gets very hot.the oil pressure guage is at the rocker box and gooes in the reverse to a vacuum. the oil pump is new could you please advise how to fix this problem
Submitted: 6 months ago.
Category: Motorcycle
Expert:  Steve replied 6 months ago.
it sounds like you are losing the prime on the oil pump.- verify your oil line routing, ensuring the feed, return and vent are all correctly connected. DO NOT ASSUME they are correct. Harleys don't need a lot of oil pressure and run just fine with no oil when cold....for a little while. verify per a factory HD service manual. (aftermarket manuals are known to contain mistakes. it happens when they re-draw and re-write they manuals to avoid the HD copyright.)- verify the feed line is large enough to flow oil. you may have issues with anything smaller than 3/8".- verify the vent connection between the oil bag and crank case is not restricted and the vent ports in the oil bag and the crank case are not obstructed.let me know if you need more help.Steve
Expert:  Steve replied 6 months ago.
let me know if you need more help.if not, please leave a POSITIVE RATING.thank you,Steve