How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Steve Your Own Question
Steve
Steve, Motorcycle Mechanic
Category: Motorcycle
Satisfied Customers: 6828
Experience:  30+ yrs. experience, MMI, HD technician, HD early, engine rebuild/performance, bike builder, kit bike program manager, CCI 2001-2004
11090168
Type Your Motorcycle Question Here...
Steve is online now
A new question is answered every 9 seconds

I purchsed a used 1998 Harley Davidson Ultra Classic. When I

Customer Question

I purchsed a used 1998 Harley Davidson Ultra Classic. When I toggle the crusie control switch it lights up but I do not get a light in the guage - and the set button does not seem to work. I've looked in the Harley Davidson shop manual and can not find how to trouble shoot this or what could be wrong. Thanks
Submitted: 9 months ago.
Category: Motorcycle
Customer: replied 9 months ago.
I did the switch test and it failed. The cruise light did not come on so i check the continuity and the switch ohms out at .8 and steady. the cruise just wont in gauge..Help
Expert:  Steve replied 9 months ago.

tell me about when this started.

did you perform any maintenance or ad any accessories?

tell me everything you can about when the cruise worked fine until now.

tell me everything you can.

Steve

Customer: replied 9 months ago.
Well ... Last summer there was a short under the seat in the main wiring harness that caused the brake light to stay on. Someone had removed the trailer hitch and just cut the wires off from were they had tapped in to the main harness and slapped some kind of black gummy paste on the wires and called it done. After I tracked down the short I had to separate the wires and tape them up. Then the cruise control stopped working. Now and again it would work but now not at all.
Expert:  Steve replied 9 months ago.

that brake light wiring issue is the cause of your problem now.

when the cruise senses the brake light, it disengages.

you need to correct this issue. tape is unacceptable. the broken wires need to be soldered and covered in shrink tubing.

let me know if you need more help.

Steve

Customer: replied 8 months ago.
Well I replaced the rear harness with a new one and I still have the same problem..No cruise at all and no solid green light when I press the cruise set button and turn the ignition on..Any other ideas????
Expert:  Steve replied 8 months ago.

based on what you posted previously, it is still possible the bike has wiring issues.

- the throttle IDLE cable roll off switch disengages the cruise. "switch closed" disengages the cruise. if you remove the wires from the spade connectors on the switch, you can eliminate that as a possible cause. IF removing the wires causes the cruise function to return, you will need to perform a throttle cable adjustment.

- this is a common issue after replacing the throttle and/or idle cables. it would be unusual to just happen for no reason.

the brake light and the roll off switch are the only two things on the bike that turn the cruise off. if they are both functioning correctly, the only possible causes of your problem are a wiring problem with one of the harnesses on the bike associated with the cruise module, or a problem with the module itself.

Steve