How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Motorcycle
Satisfied Customers: 24656
Experience:  17 years automotive training and experience.
14928985
Type Your Motorcycle Question Here...
Pete is online now
A new question is answered every 9 seconds

I have a 2008 polaris 500 x2. It won't go over 20mph seems

Customer Question

Customer: I have a 2008 polaris 500 x2. It won't go over 20mph seems to really dog down. Tried checking fuel pressure at the pump outlet, the pump will run for about 2 sec then shuts down, I replaced the pump last year due to low pressure 31 psi, new pump built up to 41 psi seems last year the pump ran as long as the key was on, am thinking the the ECM may be the problem.
JA: Thanks. Can you give me any more details about your issue?
Customer: Well, I think I may have caused it, I was using a 12v oven plugged into the receptacle on the side of the headlite pod blew several fuses over several days last fuse blew I replaced machine started and ran fine went about 100 yards and the machine really powered down with a steady throttle trying to go about 20 mph I unplugged the oven and the machine took off and ran really good with no issues for about 30 miles, I parked the machine for the night went out to go on a ride the next day and it dfeveloped the running problem.
JA: OK got it. Last thing — JustAnswer charges a fee (generally around $18) to post your type of question to Motorcycle Experts (you only pay if satisfied). There are a couple customers ahead of you. Are you willing to wait a bit?
Customer: Yes
JA: OK. Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 11 months ago.
Category: Motorcycle
Expert:  Pete replied 11 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

Check and see if there is any melted or corroded power or ground cables leading from or at the battery itself.If there are any cable issues the cables will need to be corrected to resolve this issue here,in some cases drawing extra power like this can cause cables to heat up and fail or melt/corrode and may cause issues like this here.If this is or has been checked and found to be o.k. let me know so we can continue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete