How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Motorcycle
Satisfied Customers: 25352
Experience:  17 years automotive training and experience.
14928985
Type Your Motorcycle Question Here...
Pete is online now
A new question is answered every 9 seconds

IVE GOT A 2001 POL Sportsman 500 ho and it had been sitting

Customer Question

Customer: IVE GOT A 2001 POL Sportsman 500 ho and it had been sitting for 2 years, had no spark so replaced stator and trigger coil , cleaned carb and she fires up and idles but a little rough. give any gas and she backfires and stalls out. so I did a compression test got 123psi. then did a leakdown test and exhaust valves were leaking pretty good lapped the valves and they are still leaking.
JA: Thanks. Can you give me any more details about your issue?
Customer: this model has the auto decompression do I need to do anything different for the leakdown test?
JA: OK got it. Last thing — JustAnswer charges a fee (generally around $18) to post your type of question to Motorcycle Experts (you only pay if satisfied). There are a couple customers ahead of you. Are you willing to wait a bit?
Customer: sure
JA: OK. Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 1 year ago.
Category: Motorcycle
Expert:  Pete replied 1 year ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

If you have not drained out the fuel tank and cleaned the tank and added new fuel and a new fuel filter I would do this before anything else.Then re check and see if the issue here continues.In some cases you can get debris or water in the fuel which can cause a lean condition causing this fault here.

If this was already done let me know.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete