How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Motorcycle
Satisfied Customers: 27197
Experience:  17 years automotive training and experience.
14928985
Type Your Motorcycle Question Here...
Pete is online now
A new question is answered every 9 seconds

06 ski doo mach z 1000 sdi. No headlights tail lights brake

Customer Question

06 ski doo mach z 1000 sdi. No headlights tail lights brake light
Submitted: 1 year ago.
Category: Motorcycle
Expert:  Pete replied 1 year ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.My info is somewhat limited on your model here but I had seen no one else has responded and would like to see if I can help here.If at any time you feel that I cannot help with this please let me know.

Check for any broken or damaged wiring needing repaired in the engine bay as well as running to the light switch.If a fault is found with any of the wiring it will need to be repaired to correct this issue here.If this has already been checked and found o.k. let me know so we can continue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 1 year ago.
All the wiring is good if I disconnect it through out the system and apply direct power they will light I put new new relays and new fuses for some reason the I believe f7 and f8 fuses won't get power it's the lighting fuse and secondary load fuse
Expert:  Pete replied 1 year ago.

O.k.,have you checked the wiring connections at these fuses for any corrosion or damage?

Customer: replied 1 year ago.
everything's cleaned nothing split or broken I actually take really good care of it very clean well kept and always in garage unless on the snow my switch only controls high and low on and off works when sled starts lights on when off lights off. When I hit high low switch the indicator doesn't even appear in the gauge and also when this started the check engine light started flashing don't know if it's related or not or if it's like a car and I can just hook up a code reader but I can find a plug if I could and on this model with it saying secondary load I'm not sure if ttheres 2 volt reg or just one big one with something having a glitch in it all my other lights work as far as gauge lights its just head and tail lights
Expert:  Pete replied 1 year ago.

O.k.,unfortunately my info is limited on this model here.

I will open your question up for others here to see if someone else can assist further on this as there may be others here that may have more info on what to check or do with this issue.I hope you can get this resolved with ease.No need to reply to my last post here unless it is a last resort as it will keep your question locked to me and others will not be able to view it.If you feel you want to continue to work with me on this feel free to reply at any time but keep in mind in some cases it can be difficult to fully diagnose or help repair this without seeing your vehicle.

Thanks Pete

Customer: replied 1 year ago.
Ok thank you

Related Motorcycle Questions