How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask P.J. Your Own Question
P.J.
P.J., Technician
Category: Motorcycle
Satisfied Customers: 750
Experience:  10 years as a mechanic and fabricator in a privately owned, local, custom bike shop.
75205684
Type Your Motorcycle Question Here...
P.J. is online now
A new question is answered every 9 seconds

I very carefully removed the tour pack from my '03 Electra

Customer Question

Hi, I very carefully removed the tour pack from my '03 Electra Glide Ultra Anniversary, and zip tied the connections to tuck under the seat. Now the radio doesn't work at all - lcd screen is blank and no sound. I checked all fuses and everything looks good. By disconnecting the rear speakers on the tour pack did I confuse the circuitry, or is there a ground required to complete the circuit?
Submitted: 1 year ago.
Category: Motorcycle
Expert:  P.J. replied 1 year ago.

If the fuse checks out good then your problem is likely coincidental. There are trouble codes that can be set due to radio wiring being shorted or connected incorrectly but they would not cause your problem.

Radio Sound Inc are the only people I know of that can diagnose and repair your radio.

I hope this helps, thanks, P.J.