How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Bike-Doc Your Own Question
Bike-Doc
Bike-Doc, Motorcycle Mechanic
Category: Motorcycle
Satisfied Customers: 671
Experience:  I have fixed & modified bikes for 35 yrs I'm now THE Mobile Bike Mechanic for S.LONDON since 1990
38097336
Type Your Motorcycle Question Here...
Bike-Doc is online now
A new question is answered every 9 seconds

I have a 2001 polairs 500 ho wont ldle good and backfires

Customer Question

I have a 2001 polairs 500 ho wont ldle good and backfires through intake and exaust I have check cam lobes and lobes are in spects set vales to .006 and take carb off and clean and replace all jets and rubber diphane and check fuel pump with vacuum on vacuum line and holds 5in of vacuum and also line from motor has plusing vacuum also tried new spark plug the only thing I can see is I can not see timming marks through hole when idleing please I need help
Submitted: 1 year ago.
Category: Motorcycle
Expert:  Bike-Doc replied 1 year ago.

Hi Chad
Welcome to JustAnswer

My name is***** am a professional here at JustAnswer.com

Sorry to have to ask what may seem like stupid questions, but it is obviously difficult diagnosing problems remotely, I cannot hear, see, touch or smell anything so I have only what a customer tells me to make a correct diagnosis.
Also I dont know how proficient a customer is or what they may have done already. So I need to ask stuff which may seem obvious or unrelated

Has she been laid-up (unused) for any length of time?

Have you done a compression test ?

Thanx

Ride Safe

Bike-Doc

Expert:  Bike-Doc replied 1 year ago.

I recommend a compression test to totally eliminate the valves from this problem

Not being able to see the firing marks is disconcerting

Give me a short while to check whether they are ignition timing or valve timing marks

Back shortly

Expert:  Bike-Doc replied 1 year ago.

This is 'Old Skool' as they say; its rare that the stator plate position can be altered these days but yours can

Which makes it much more likely that the plate has come loose rather than something expensive like the ECU going bad

Expert:  Bike-Doc replied 1 year ago.

If you cant even see the marks with a strobe then she must be firing way out of time

You will need the correct flywheel puller

Are you familiar with the procedure? or would you like a walk-through

I have the manual to quote from btw

Please dont rate my service before giving me a chance to help you, negative (low) ratings are taken seriously here & I will try my best to help you as much as I can (for both our sakes)

Giving an undeserved negative or low rating will also put off other experts from trying to help

Ratings apply solely to the service an expert gives you, they do not apply to JustAnswer.com or its policies.

Expert:  Bike-Doc replied 1 year ago.

Hi

Your question has appeared back on my list at last

I believe you said the timing plate is secure,correct?

Was the Woodruff key intact & not bent ? Ive seen keys broken in half so the rotor goes out of line

But the most likely thing is the ECU unfortunately

Please dont rate my service before giving me a chance to help you, negative (low) ratings are taken seriously here & I will try my best to help you as much as I can (for both our sakes)

Giving an undeserved negative or low rating will also put off other experts from trying to help

Ratings apply solely to the service an expert gives you, they do not apply to JustAnswer.com or its policies.

Expert:  Bike-Doc replied 1 year ago.

Any joy?

Please let me know if its fixed & what it was, if only for the sake of my curiosity

Thanx

Ride Safe

Bike-Doc