How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Bike-Doc Your Own Question
Bike-Doc
Bike-Doc, Motorcycle Mechanic
Category: Motorcycle
Satisfied Customers: 671
Experience:  I have fixed & modified bikes for 35 yrs I'm now THE Mobile Bike Mechanic for S.LONDON since 1990
38097336
Type Your Motorcycle Question Here...
Bike-Doc is online now
A new question is answered every 9 seconds

I turn on key and all lights work & brake lights and when I

Customer Question

i turn on key and all lights work & brake lights and when I hit the start button nothing no click clunk nothing?New battery,new switches,new ignition switch.
Submitted: 1 year ago.
Category: Motorcycle
Expert:  Bike-Doc replied 1 year ago.

Hi Jeff
Welcome to JustAnswer

My name is***** am a professional here at JustAnswer.com
I noticed that your question has not received a response yet and thought I would see if you still want the problem diagnosed.
I apologize for the delay and hope I can assist you with your question.

My info is somewhat limited on your model but as no one else has responded I will try to help you.

Do you still want help with this problem?

By new switches I guess you mean handlebar switches, correct?

Do you have a multi-meter?

Is there power at the starter solenoid ?

Sorry to have to ask what may seem like stupid questions, but it is obviously difficult diagnosing problems remotely, I cannot hear, see, touch or smell anything so I have only what a customer tells me to make a correct diagnosis.
Also I dont know how proficient a customer is or what they may have done already. So I need to ask stuff which may seem obvious or unrelated

Thanx

Ride Safe

Bike-Doc

Expert:  Bike-Doc replied 1 year ago.

Let me guess then:-

Bad ground, loose battery connection, bad connection from start button to solenoid, bad solenoid?

If you havent checked these things already then then check them out & get back to me please, even if just to satisfy my curious mind

Please dont rate my service before giving me a chance to help you, negative (low) ratings are taken seriously here & I will try my best to help you as much as I can (for both our sakes)

Ratings apply solely to the service an expert gives you, they do not apply to JustAnswer.com or its policies.

So if you feel you should give me a low rating, please contact me 1st & I will strive to reverse that feeling

Thanx

Ride Safe

Bike-Doc

If I have already helped you then please press accept as that is the only way that I am compensated for my input, this does not close your question, it will stay open for its 7 day lifespan! (or longer)