How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kenny O. Your Own Question
Kenny O.
Kenny O., Motorcycle, ATV, Mules, Side by Side's Product Specialist. All Brands
Category: Motorcycle
Satisfied Customers: 953
Experience:  Worked for Kawasaki Motors as a Product Support Specialist (Factory Support) for 24 years
30381042
Type Your Motorcycle Question Here...
Kenny O. is online now
A new question is answered every 9 seconds

Have 2007 kawasaki 650 brute force atv ran well last season

Customer Question

have 2007 kawasaki 650 brute force atv ran well last season set up for about two months now it starts ok but sputters on top end will only run on full choke
Submitted: 1 year ago.
Category: Motorcycle
Expert:  Kenny O. replied 1 year ago.

Thanks for the request ! it sounds like the low speed circuits are fouled up, this usually happens when the fuel becomes unstable, todays fuels and the way they are formulated don't have a very long shelf life.

Something you can try first is try an additive that you can find at Home Depot in the Lawn and Garden section, its call Mechanic in a Bottle, follow the directions on the bottle first and it can actually clean up jets (depending how long the un its been sitting and how gummed up they are) give it some time and I have seen where it actually works where the unit will start to idle once again, if you have no success then you'll have to have the carbs professionally cleaned. Meaning they will need to be completely disassembled and gone through, I would try the additive I have listed first then see how that works.

Let me know if this helps, if not please get back and I will be glad to help you further !

Thanks

Kenny