How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask TIMOTO Your Own Question
TIMOTO
TIMOTO, Motorcycle Mechanic
Category: Motorcycle
Satisfied Customers: 1445
Experience:  Honda registered technician, silver level award, former Kawasaki/Suzuki tech, 40+ years exp.
8313095
Type Your Motorcycle Question Here...
TIMOTO is online now
A new question is answered every 9 seconds

I have a honda Ct90,k-3. Runs excellent when cold, run two

Customer Question

I have a honda Ct90,k-3. Runs excellent when cold, run two miles at 35 to 40mph and it starts to lose power then dies. 15 to 30 seconds it starts and runs but barely over 30mph.Things done:new OEM coil,carb cleaned with rebuild kit, gas tank cleaned and sealed, new gas lines, valves adjusted,new points adjusted and timed. All work done by me, I'm not a pro mechanic.
The carb cleaning,done first, helped initially with low speed performance.
The high speed problem has been the same. Help.
Submitted: 1 year ago.
Category: Motorcycle
Expert:  TIMOTO replied 1 year ago.

One possibility is a clogged vent on the fuel tank. Try removing the fuel tank cap and rune it that way. The tank vents through the gas cap so removing it should cure the problem is that is the cause.