How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Motorcycle
Satisfied Customers: 27197
Experience:  17 years automotive training and experience.
14928985
Type Your Motorcycle Question Here...
Pete is online now
A new question is answered every 9 seconds

I HAVE A 2014 RZR AND I HAD A TWO BROTHERS EXHAUST (SINGLE)

Customer Question

I HAVE A 2014 RZR AND I HAD A TWO BROTHERS EXHAUST (SINGLE) SLIP ON PUT ON IT AND I HAVE A BIG LOSS IN POWER AND MY RPMS IN DRIVE ONLY GO TO 5900 WHEN 6500 IS NORMAL AND I HAVE A PROGRAMMER POWER COMANDER 5 WITH THE RIGHT MAP.
Submitted: 1 year ago.
Category: Motorcycle
Expert:  Pete replied 1 year ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
My info is limited on your model here but I see no one else has responded and thought I would see if I can help here.
Even with this exhaust being new and installed it may be partially restricted or causing to much back pressure in the exhaust and can cause this here.I would have this checked/tested to see if this is the cause.
Thanks Pete

Related Motorcycle Questions