How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Motorcycle
Satisfied Customers: 24659
Experience:  17 years automotive training and experience.
14928985
Type Your Motorcycle Question Here...
Pete is online now
A new question is answered every 9 seconds

I have a 2007 Harley Electra Glide Ultra Classic. I washed

Customer Question

I have a 2007 Harley Electra Glide Ultra Classic. I washed it and rode home stopping a couple of places started and ran fine. Next morning it would not start. It starts on sprayed carb cleaner but dies when that runs out. No check engine light unable to pull codes due to bad odometer reset switch.I have replaced the fuel pump and fuel filter kit. I removed and inspected the fuel hose to the check valve and substituted a known good battery and still no start. It initially started when I first replaced the fuel filter but would bog out badly with high fuel demand until it became no start again.
Submitted: 1 year ago.
Category: Motorcycle
Customer: replied 1 year ago.
I have checked all the fuses in both fuse blocks and the connectors that are easily accessable.
Customer: replied 1 year ago.
Well you have my money any ideas what to check on this problem Sturgis is next week
Customer: replied 1 year ago.
Tried to start it and it almost sounded like it kicked back like it was out of time and backfired through throttle body.
Expert:  Pete replied 1 year ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
I apologize my info is limited on your model here.
With the back fire and kick back this sounds like a fault with a lack of fuel as a lean engine running condition will cause this here.
I would have the fuel line and components checked into further for any restrictions causing this issue needing repaired.
Thanks Pete