How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jeff Policky Your Own Question
Jeff Policky
Jeff Policky, Motorcycle Mechanic
Category: Motorcycle
Satisfied Customers: 2425
Experience:  Yamaha Gold, Suzuki Gold, Honda Bronze, Polaris Bronze, BRP
17258690
Type Your Motorcycle Question Here...
Jeff Policky is online now
A new question is answered every 9 seconds

2001 Yamaha venture. Runs great when first started (COLD) and

Customer Question

2001 Yamaha venture. Runs great when first started (COLD) and then begins to run rough after it warms up (10 minutes). Spark plugs look OK. Most noticeable under a pull (like up hill or hard acceleration). Engine vibration at highway speeds (60-65 mph).
What could it be?
Submitted: 1 year ago.
Category: Motorcycle
Expert:  Wayne S. replied 1 year ago.
If your plugs are okay I would suspect the plug cap resistors and the plug wires might be failing. If the plug colors are reasonablethe fuel mixture may be okay but the spark is weak at higher rpm.Make sure battery is good and cables are tight.Plug cap resistors can get corroded over time.Plug wires can also start to fail after many years of use.Carbs if you have them need to be syncronized and balanced.Some water in the fuel could possibly cause this butit would affect slow running too.Plug cap rubbers can short out to the engine when old.Might be able to see that at night if they misfire.Check your air filter too.WS----