How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask P.J. Your Own Question
P.J.
P.J., Technician
Category: Motorcycle
Satisfied Customers: 750
Experience:  10 years as a mechanic and fabricator in a privately owned, local, custom bike shop.
75205684
Type Your Motorcycle Question Here...
P.J. is online now
A new question is answered every 9 seconds

I have a*****glide I seem to have an engine

Customer Question

I have a*****glide I seem to have an engine light issue if you shut the bike off turn back on, the light goes out. you go 10 miles or so it comes on I have brought to 2 Harley dealers & to a custom bike builder none can find the issue they clear it & it will go for a while and then comes back 1 dealer told me to put tape over it good answer ha.it does not affect my charging or the running of the bike at all. Scott
Submitted: 1 year ago.
Category: Motorcycle
Expert:  P.J. replied 1 year ago.
A little more information may be helpful. Do you know what code(s) is turning the light on? Are your gauges stock? Is your ECM stock?
Customer: replied 1 year ago.
code I was told general engine code , I have vance & hines pipes a power camander & stock ecms, & gauges are stock
Expert:  P.J. replied 1 year ago.
There isn't a general engine code. I'm not sure why they would not tell you specifics. Strange. Anyway, when you have a chance, use the attached instructions to retrieve the diagnostic trouble code(s) and let me know what numbers are in there and maybe it will help us figure it out.After that, I'd also suggest just removing the Power Commander to see if the problem stops. The Power Commander is a good unit but they are notorious for having connection problems and causing odd issues. It is especially true on a bike like yours where the seat can put pressure on the ECM connection. It will not harm the bike to run without the Power Commander.Thanks, P.J.
Customer: replied 1 year ago.
u know it might be the fact that I am sitting on the commander & when I put preasure it activates it
Expert:  P.J. replied 1 year ago.
It happens...especially with aftermarket seats or if the plugs are not arranged in an out of the way place. If you look on the underside of your seat pan you'll usually see a "pressure point" mark with a corresponding wear mark on the a plug or module. That is the tell-tale. It's the first thing that I always check when odd problems show up. Thanks, P.J.
Customer: replied 1 year ago.
I will check it out
Expert:  P.J. replied 1 year ago.
Ok, let me know if I can be of further assistance. Thanks, P.J.