How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Steve Your Own Question
Steve
Steve, Motorcycle Mechanic
Category: Motorcycle
Satisfied Customers: 6828
Experience:  30+ yrs. experience, MMI, HD technician, HD early, engine rebuild/performance, bike builder, kit bike program manager, CCI 2001-2004
11090168
Type Your Motorcycle Question Here...
Steve is online now
A new question is answered every 9 seconds

2001 ultra, ignition comes on, but fuel pump switch does nothing.

Customer Question

2001 ultra, ignition comes on, but fuel pump switch does nothing. I no longer hear the pump. Turns over fine. Did same thing last year then suddenly started working again. Think its a bad switch at the throttle?
Submitted: 1 year ago.
Category: Motorcycle
Expert:  Steve replied 1 year ago.
your bike has no fuel pump switch.the switch on the right hand control is the kill switch (run/stop) for the entire fuel management system.IF the starter cranks the engine when the switch is in RUN, the switch is good. your fuel pump (and also the injectors and coil) are powered from a FUEL SYSTEM RELAY under the right side cover (behind the right saddle bag).the other relay in that same location is the ECM relay.there is a small (2 fuse) fuse block as well with an ECM fuse and a FUEL SYSTEM fuse.if it were my bike, I would replace both relays. they probably have burned contacts by now.let me know if you need more help.Steve
Customer: replied 1 year ago.

ok, i will order two new relays and go from there. Thanks!

Expert:  Steve replied 1 year ago.
let me know if you need more help.Steve
Customer: replied 1 year ago.

Replaced relays, no change. Fuel pump still not coming on

Expert:  Steve replied 1 year ago.
- did you replace the fuses?- remove the seat and check for 12v at the fuel pump connector. there will only be voltage present for about 4 seconds after turning the ignition switch to ignition. after that, only when the starter is cranking he engine or when the engine is running. - if the pump has power and does not run, the pump is bad and will need to be replaced. let m know if you need more help.Steve
Expert:  Steve replied 1 year ago.
let me know if you need more help.
if not, please leave a POSITIVE RATING..
thank you,
Steve