How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Steve Your Own Question
Steve
Steve, Motorcycle Mechanic
Category: Motorcycle
Satisfied Customers: 6833
Experience:  30+ yrs. experience, MMI, HD technician, HD early, engine rebuild/performance, bike builder, kit bike program manager, CCI 2001-2004
11090168
Type Your Motorcycle Question Here...
Steve is online now
A new question is answered every 9 seconds

I replaced the battery on a 2004 electra glide, CVO.AFTER

Customer Question

I replaced the battery on a 2004 electra glide, CVO.
AFTER I reconnected the main cables and 2 other cables that don't know where they go, the bike starts but the red key light stays on. Also the right turn signal does not work. And the tail light does not come on.
If I disconnect the 2 set of wires the red light shuts off.
right turn signal works but when activated the front left turn signal comes on as well.
left turn works fine
4 ways work.
tail light still does not work.
Submitted: 1 year ago.
Category: Motorcycle
Customer: replied 1 year ago.
Also last week my sterio quit working it turns on but no sound comes out.
The one set of the wires connected to the battery makes my speakers crackle when I connect them to the battery
Expert:  Steve replied 1 year ago.
- the extra wires connected to the battery are an accessory. you need to find out what it is and where it is and if you even want it on your bike. it must be something the previous owner added. whatever it is, it should not be connected to the battery. there is an accessory connector under your seat for things like that. this only indicates whoever added the accessory was not a professional and may have not even wired the thing correctly.- if you activate the right turn signal and the left AND right signals operate, it indicates a problem with the wiring between the right and left hand controls.if your bike does not have the HD security system, the red "key" light is caused by a fault in the turn signal module.- replace the tail light bulb and check the operation of the tail light. let me know if you need more help.Steve
Customer: replied 1 year ago.
The first set of advice was of no help at all. These things worked before the batter replacement and should work nowE mail to tech I replaced the battery on a 2004 electra...
I replaced the battery on a 2004 electra glide, CVO. AFTER I reconnected the main cables and 2 other cables that don't know where they go, the bike starts but the red key light stays on. Also the right turn signal does not work. And the tail light does not come on. If I disconnect the 2 set of wires the red light shuts off. right turn signal works but when activated the front left turn signal comes on as well. left turn works fine 4 ways work. tail light still does not work.With none of the 4 wires hooked up tail light does not work.
Tail lite works when I connect 1 set of wires but causes issues like taillight and rear turning lamps stay on even when bike is off.With no wires connected left turn signal works but flashes very fast. The right turn signals work but it also makes the left front blinker come on.One set of the wires go twords the back. Looks like it go's to trailer hitch, and branches out to many other locations.
The other set seems to run forward under the tank and maybe into the fairing
Expert:  Steve replied 1 year ago.
best of luck.Steve
Customer: replied 1 year ago.
Can we get the new tech to respond as quick as possible. . this is urgant