How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Eric Your Own Question
Eric, Technician
Category: Motorcycle
Satisfied Customers: 1533
Experience:  MMI grad. 7 years experience in Honda, Suzuki, Yamaha, as service manager and tech.
Type Your Motorcycle Question Here...
Eric is online now
A new question is answered every 9 seconds

2006 honda rancher 350 4x4 electric shift isnt working at

Customer Question

2006 honda rancher 350 4x4 electric shift isnt working at all.n for neutral blink twice then pauses for a second and repeats doing that.if its a sensor,whats it look like and where is it located?will one fit off a 2001?any ideas are appreciated
Submitted: 4 years ago.
Category: Motorcycle
Expert:  Eric replied 4 years ago.


the blinking twice is a fail code. in this case code 2. when anything with the ESP fails it will cease to shift electricaly. The code two pertains to the up/down shift buttons and its harness. typically this code come up after the atv has been very wet, whether it be from heavy mud and ect. or more typically powerwashing the atv. that switch assembly has a harness that runs up under the front fender to a large gray connector. i would get to that connector and disconnect it, then check for moisture. this is typically where you would find water if there is any. you can blow that connector out with comrpessed air, as well as the harness. if this doesnt cure your code two then there is a short in the harness. one from a 2001 may work if that is the case.

Customer: replied 4 years ago.
its dried now but still shifts really rough.i didnt have it in much water.i think there is a sensor at the back of motor on bottom of motor could this be a problem and will sensor from 2001 work
Expert:  Eric replied 4 years ago.
there is a sensor at the back bottom of the engine, but that is the neutral indication sensor, that would not pertain to your type of problem. that sensor bad would typically not allow you to shift to reverse only. there is one midway up the back of the engine, that is the gear position switch, that would not cause the motor to shift hard either. if the shift is barely happening, then the shift motor itself may have dirty contacts internally, or there are small shift reduction gears that the shift motor turns, you will notice that he plate that this shift motor turns can be unbolted from the front of the motor as well, and this will contain the shift reduction gears. if one or any sensor was acting up it would show as a code. the computer on these are pretty good about failing out when one of the sensors are bad. the only one that is commonly intermit would be the angle sensor at the front bottom of the engine, however this would sometimes show up with three flashes.
Customer: replied 4 years ago.

how do i find out what the codes are?


Expert:  Eric replied 4 years ago. click on this link and it will show them as well as some other helpful info.
Eric and other Motorcycle Specialists are ready to help you
Customer: replied 4 years ago.
ok i checked big grey plug-no moisture.checked big green plug-full of water.used air compressor on both and still shifts rough like your shifting with throttle half way on
Customer: replied 4 years ago.
sorry forgot to tell you that it isnt showing codes now ,just shifts really rough
Customer: replied 4 years ago.
just tried the codes it blinks twice,pauses blinks once and keeps repeating.
Customer: replied 4 years ago.
Relist: Other.
no answer
Customer: replied 4 years ago.
Do you know a website I can download a service manual