How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Mitsubishi
Satisfied Customers: 22539
Experience:  ASE Master and Advanced level certified. Factory trained with 15 years dealership experience
9825021
Type Your Mitsubishi Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

My speedo has stopped working in my mitsubushi lancer cedia,

Customer Question

My speedo has stopped working in my mitsubushi lancer cedia
JA: What year is your Lancer?
Customer: 2002
JA: Are you fixing your Lancer yourself? What have you tried so far?
Customer: I would like to fix it myself
JA: Anything else you want the mechanic to know before I connect you?
Customer: Looking fr the easiest option
Submitted: 8 months ago.
Category: Mitsubishi
Customer: replied 8 months ago.
I would like to fix the issue myself and would like to try any other options to fix it please
Customer: replied 8 months ago.
Im waiting for a reply ive paid $27
Expert:  Randall replied 8 months ago.

Hello, sorry for the delay, One has to pull up the vehicle diagrams etc to begin helping. Cant send and asap answer, I am sorry for that, Now, do you have manual or auto trans?

Customer: replied 8 months ago.
Auto
Expert:  Randall replied 8 months ago.

Is car shifting and running ok?

Customer: replied 8 months ago.
Whats the cause? Is it the speedo sensor? Or is it loose? Um my speedo sits on zero and my odometer reading has frozen aswel if that helps the revs to the left still works and the temp and fuel gauge to the right still works also
Customer: replied 8 months ago.
The car over all is fine drives well jst suddenly the speedo stopped
Expert:  Randall replied 8 months ago.

Ok, chances are you have a bad output shaft sensor on top of the transmission, There are 2 sensors mounted on top of the trans. The output sensor is what send vehicle speed to the computer for the speedometer. In most cases, say 90% that output shaft sensor has failed, Sure the speedo could be bad, I cant say that for sure but most common the speed sensor is bad, It si mounted on top of the trans, is the one with a BLUE /YELLOW & RED & Black wires going to it, Its call the output shaft sensor. Here is a link showing the sensors on top of the trans

Customer: replied 8 months ago.
Oh ok cool thank you so much I will go see if I can get it fixed
Expert:  Randall replied 8 months ago.

it will look like this in the link

Please rate my service provided today, Thanks

Customer: replied 8 months ago.
Do you have a clear pic of location of part please is it under the battery
Expert:  Randall replied 8 months ago.

i do not, sorry. I do know both input and output are on top of trans. I cant remember all to be removed but need to expose the top of the trans in any case

Customer: replied 8 months ago.
Hi there one final question would you the price of a replacement output sensor nz please
Expert:  Randall replied 8 months ago.

I am not in parts but checking on my end, they run between $24-$48 US, Unsure of differnce but looks to be factory vs aftermarket which is cheaper,Quality? cant answer that, The shop generally gets us aftermarket parts and they fair just fine

Customer: replied 8 months ago.
Hi there do you have pictures of the location of the output sensor please in real time not a diagram
Expert:  Randall replied 8 months ago.

I only have access to what I sent factory repair wise, I sill go ahead and opt out and open the post to the other experts, If one can continue to help? they will be along shortly, please save the rating for the expert that can send your requested information

Customer: replied 8 months ago.
The output sensor in got dd not fit do turbo and non turbo output sensor different mine is turbo
Expert:  sprinkles08 replied 8 months ago.

Hello and welcome to Justanswer!

Do you still need help?

Related Mitsubishi Questions