How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka- Moose) Your Own Question
Chris (aka- Moose)
Chris (aka- Moose), Technician
Category: Mitsubishi
Satisfied Customers: 43928
Experience:  16 years of experience
Type Your Mitsubishi Question Here...
Chris (aka- Moose) is online now
A new question is answered every 9 seconds

I have a 2003 diamanté, the instrument cluster lights have

Customer Question

I have a 2003 diamanté , the instrument cluster lights have stopped working for sometime now. I've pulled the cluster and checked the bulbs through direct connection and they work fine. All fuses relating to the instrument cluster and radio have been checked and are fine. There must be a bad connection somewhere but I'm not sure where
Submitted: 24 days ago.
Category: Mitsubishi
Expert:  Chris (aka- Moose) replied 24 days ago.

Welcome, I'm Chris (aka Moose) I prefer to work when others don't, I am here around lunch and after dinner till after midnight.

  • Sorry no one has helped yet.
  • This is not an answer to your question, just an inquiry if your still needing/wanting help. Because I believe I can help.
Customer: replied 23 days ago.
still need the issue resolved
Expert:  Chris (aka- Moose) replied 23 days ago.

Lets check the illumination power and ground to the cluster using the diagram below.

This is my 1st answer, but does not have to be my only answer. You the website and myself expect you to have a ~~~5 STAR EXCELLENT~~~ experience with my help. Please let me know if you are pleased by selecting a star rating above or by replying and saying your pleased. Not rating or rating 1-2 stars does not benefit you nor me in any way. Follow up and reply as often and when needed, there is no extra charge to do so.

Thanks Moose.

Customer: replied 23 days ago.
From the rheostat?
Customer: replied 23 days ago.
I'm no getting any power from the green/white wire at any point, none from the clock button plug, none from the dimmer plug
Expert:  Chris (aka- Moose) replied 23 days ago.

Does the illumination on the illumination at the TCS switch and ashtray work?

Customer: replied 23 days ago.
Not sure where the tcs is but the ashtray has no lighting. I installed a new head unit awhile back and there are what looks to be 2 antenna plugs but the aftermarket head units have one fitting soci left the smaller undone, not sure of that has anything to do with it
Expert:  Chris (aka- Moose) replied 23 days ago.

Is dedicated fuse 1 under the hood powered with the headlights on?

Is the instrument cluster black/yellow wire showing continuity to ground?

Expert:  Chris (aka- Moose) replied 20 days ago.

Hello again Chris here,

  • I am following up with you to see if you got everything you needed from my answer.
  • I have not heard back from you, so I assume you were not pleased. We're you pleased with my help?
  • If you were not pleased with my help, please let me know by replying so I can help more.
  • This post is coming up on the 7 day mark where it times out. When a post times out, that means it's no longer on my active list (you reply and I may never know it.)

Thanks Chris

Related Mitsubishi Questions