How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka- Moose) Your Own Question
Chris (aka- Moose)
Chris (aka- Moose), Technician
Category: Mitsubishi
Satisfied Customers: 43875
Experience:  16 years of experience
Type Your Mitsubishi Question Here...
Chris (aka- Moose) is online now
A new question is answered every 9 seconds

I have 2003 outlander awd I have 5.9 volts going to the fuel

Customer Question

I have 2003 outlander awd I have 5.9 volts going to the fuel pump could it be the relay or some ind of sensor.
JA: Are you certain it's the fuel pressure sensor that's in need of attention? What about the fuel rail? Have you checked it yet?
Customer: the car will start if I spray starting fliud in it
JA: What is the model of your '03 Mitsubishi?
Customer: outlander awd
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: trouble shooting to see if
JA: Anything else you think the mechanic should know?
Customer: trouble shooted the fuel pump with a volt meter and got 5.9 volts coming into it shouldn.t there be 12
Submitted: 2 months ago.
Category: Mitsubishi
Expert:  Chris (aka- Moose) replied 2 months ago.

Welcome, I'm Chris (aka Moose) I prefer to work when others don't, I am here around lunch and after dinner till after midnight.working after noon till just after midnight.

  • Sorry no one has helped yet.
  • Yes, you have been charged already.
  • Yes, I am aware of the time you asked your question and time I am responding.
  • I will be online a couple more hours after this post.
  • This is not an answer to your question, just an inquiry if your still needing/wanting help. Because I believe I can help.
Expert:  Chris (aka- Moose) replied 2 months ago.

This sounds more like dirty contacts in the pump relay. Did you use the pump ground wire for this test, if so the ground could have resistance.

Expert:  Chris (aka- Moose) replied 2 months ago.

Hello again Chris here,

  • I am contacting you because the post has not been closed out/completed.
  • It appears you were not pleased with my help.
  • If more assistance is needed, reply and let me know, also let me know what it is you're needing to be pleased.
  • This post is coming up on the 7 day mark where it times out. When a post times out, that means it's no longer on my active list (you reply and I never know it.)
  • You have already paid the fees to get this question answered, and I do not want you to leave having paid for something that did not meet your wants/needs and myself not receiving a feedback selection from yourself.

Thanks Chris

Related Mitsubishi Questions