How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask peterpete190 Your Own Question
peterpete190, Auto Technician
Category: Mitsubishi
Satisfied Customers: 24200
Experience:  Auto repair Technician with 17 years experience.Past ASE and other certifications.
Type Your Mitsubishi Question Here...
peterpete190 is online now
A new question is answered every 9 seconds

I purchased an 05 Mitsubishi Eclipse 5 days ago. It ran like

Customer Question

I purchased an 05 Mitsubishi Eclipse 5 days ago. It ran like a bat out of hell for approx 2 to 3 hours and then while going up a hill I shifted from 2nd to 3rd and it shifted super hard, the N light started flashing and the Check Engine light came on. I tried reading the code but a faulty ground wire prohibited that. The weird thing is I'll say 2 out of 5 times after this incident it would start up and run fine but the other 3 out of 5 it was stuck in 3rd gear but I could manually shift into 2nd. I did some research and troubleshooting via the Web and YouTube and after unplugging a couple plugs into of my transmission now when I start the car the P light is NOT lit up. It goes into reverse and neutral (both R and N light up) but dies not shift into drive (nor the D light up). It's hard for me to believe the trans is shot because of the 2 of 5 times it would run and shift flawlessly, BUT..... I have seen stranger things. Any ideas? ??
Submitted: 4 months ago.
Category: Mitsubishi
Expert:  peterpete190 replied 4 months ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

This sounds like an electrical fault with one or more of the solenoids in the transmission on the transmission valve body itself.I have seen the solenoids and sensors fail before needing replaced.You will have to get the OBD connection working to read out the fault codes as this will help diagnose and repair this issue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Related Mitsubishi Questions