How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Greg Your Own Question
Greg
Greg, Technician
Category: Mitsubishi
Satisfied Customers: 7020
Experience:  17 years shop owner, 27 year Import technician
29331485
Type Your Mitsubishi Question Here...
Greg is online now
A new question is answered every 9 seconds

Magna 3lt v6 motor breaks down between 1400 and 2000 revs

Customer Question

magna 3lt v6 motor breaks down between 1400 and 2000 revs when under load. Below and above these revs it runs fine.
things tried.
new plugs, new leads, crank, new fuel pump, air mass sensor cleaned (helped a bit) and then replaced with one from another car with no success.
Submitted: 1 year ago.
Category: Mitsubishi
Expert:  Greg replied 1 year ago.

Hi .

This is typically normally a bad TPS sensor .(very common)

Did you check for malfunction codes ?

If no code relating to the TPS then you will need to check the TPS for glitches, you will need a good scan tool that has live data .

Need any follow up help then please get back to me with the reply button, and not the poor or bad service.
This way i can get back to you or suggest another expert if needed.

If i do not get back to you then i may be off line, and when i get back online i will get back to you..

Your deposit does not pay me until the answer is rated in a positive way,
Not rating or a bad rating does not constitute a refund.

If you are not happy or you have sorted out your problem before the answer then please let me know with the reply button .

Kind regards Greg.

Customer: replied 1 year ago.
hi,
ran a scan test with no real result. showed injectors were fine and no codes came up. will try cleaning the TPS sensor and see what comes from that. The idle is rough as well now. Everyone has theory but no one has a solution yet.
Expert:  Greg replied 1 year ago.

You have a scan tool with live data, if yes what is the st trim reading at idle and then at 2500rpm

MAF reading at idle .

Sweap test the TPS for glitches, cleaning it will not do anything

Greg.

Customer: replied 1 year ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Customer: replied 1 year ago.
greg,
Didn't have scan tool yesterday but did a back probe on the tps and it was in range in both volts and ohms.
If you can find time you could ring and talk to Lindsay, he knows more about the problem than I do. 03 54552006
donald