How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Doug Your Own Question
Doug
Doug, ASE Certified Technician
Category: Mitsubishi
Satisfied Customers: 8562
Experience:  Mitsubishi employed and Factory trained ASE certified technician
21364095
Type Your Mitsubishi Question Here...
Doug is online now
A new question is answered every 9 seconds

Ok, back to the Eclipse issue. I finally had time to put a

Customer Question

Ok Doug, back to the Eclipse issue. I finally had time to put a pressure gauge on the unit. Although I only checked the end clutch. I have no oil pressure getting to the end clutch drum. I pulled the housing & drum back off to recheck lip seals & sealing
rings. Everything looked good and air checked good. Removed valve body to check for stuck valves. All ok. Installed all new solenoids. Still no overdrive.
Submitted: 1 year ago.
Category: Mitsubishi
Expert:  Doug replied 1 year ago.

Hi,

No pressure to the end clutch is certainly going to cause you a problem! If your other circuits are all reading normal and you have no pressure on end clutch in 3rd/4th this is really only going to leave an issue with the valve body or the seals on the end clutch drum/piston/etc.

Expert:  Doug replied 1 year ago.

Drop the valve body and use a air chuck with rubber nozzle and pressurize port 4 in the diagram I attached; does the port hold pressure or does it leak internally somewhere?

Customer: replied 1 year ago.
that port air checks perfect
Expert:  Doug replied 1 year ago.

Thanks.
If the port holds air pressure then that means there are no leaks leading to the end clutch assembly.... that only leaves your valve body to be at issue.
Time to pull it again and double over everything, something is preventing line pressure from reaching port 4 if you aren't seeing any pressure during the line pressure test for 3rd/4th.

Related Mitsubishi Questions