How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Amedee Your Own Question
Amedee
Amedee, Mitsubishi Technician
Category: Mitsubishi
Satisfied Customers: 24390
Experience:  ASE Technician advanced level specialist. Wisconsin certified emissions state inspector
279429
Type Your Mitsubishi Question Here...
Amedee is online now
A new question is answered every 9 seconds

03 eclipse runs and idles, but after 15 min of driving will

Customer Question

03 eclipse runs and idles, but after 15 min of driving will sputter and the die. Also will die when accelerator is compressed all the way down. What ten minuts and starts again.
Submitted: 1 year ago.
Category: Mitsubishi
Expert:  Mike V. replied 1 year ago.

Hi there,

Is the check engine light on when this is happening?

If so, do you know what codes are being stored?

Customer: replied 1 year ago.
the check engine is on. code 300
Expert:  Mike V. replied 1 year ago.

Does this have the 4 or 6 cylinder engine?

Customer: replied 1 year ago.
4
Expert:  Mike V. replied 1 year ago.

Ok, I suspect one of two possible issues happening here. Either an issue with the mass air flow sensor or possibly the catalytic converter. I would try unplugging the mass air flow sensor, then test drive the car. If it gets hot but continues to run fine, replace the mass air flow senor. If not, then I would remove the upstream O2 sensor and drive the car. If it runs better with the O2 sensor removed, replace the converter.

Please let me know if there is any more I can do to help you from here.

What happens next:
Just Answer will now charge you for the full amount of your question.
My goal is to provide you with 5-star service. If you cannot rate me at least 3-5 stars, we will keep working on this.
Just Answer does not compensate me for my time and effort; you do with a 3-5 star rating.
Follow up questions are included in your question price even after rating.

Customer: replied 1 year ago.
neither of these worked
Expert:  Mike V. replied 1 year ago.

Ok,

It's only doing this when the engine comes up to temp? Did you take the sensor out of the exhaust manifold?

Customer: replied 1 year ago.
Expert:  Mike V. replied 1 year ago.

Sorry to say, but I am going to open this back up to the other experts. Very odd problem and I don't have any other ideas. Please don't reply or it will lock the question back to me so they won't see it. Sorry I was unable to assist you with this.

Expert:  Amedee replied 1 year ago.

Hello and welcome! Different expert here. My name is ***** ***** I can assist you with your question. Would you be willing to speak on the phone? This would make it much easier for both of us.

Customer: replied 1 year ago.
Expert:  Amedee replied 1 year ago.

Please accept my offer and call me

Related Mitsubishi Questions