How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Doug Your Own Question
Doug
Doug, ASE Certified Technician
Category: Mitsubishi
Satisfied Customers: 8538
Experience:  Mitsubishi employed and Factory trained ASE certified technician
21364095
Type Your Mitsubishi Question Here...
Doug is online now
A new question is answered every 9 seconds

Mitsubishi Galant ES: i have a 2000 galant, it cranks over

Customer Question

i have a 2000 galant, it cranks over but wont fire, it has a new crank position sensor, timing is accurate, has spark and wont even fire with starting fluid.
Submitted: 1 year ago.
Category: Mitsubishi
Expert:  Doug replied 1 year ago.
Hi,What are your compression readings from each cylinder?
Customer: replied 1 year ago.
1=118
2=119
3=111
4=117
Expert:  Doug replied 1 year ago.
Yeah that's going to be a problem.Are you certain the timing belt is properly lined up? The cam gear is not rotating independently of the cam (sometimes the dowel shears off and they move out of position)? There wasn't any belt failure before hand right?
Expert:  Doug replied 1 year ago.
It looks like we missed each other last night.Please double check your timing if you are sure your compression numbers are correct, as those are definitely too low. Specification is 185 psi, and the bare minimum to successfully run the engine is 140 psi. With readings in the 110-120 range it is unlikely you would get much more than some coughs or strained firing.Having verified there is spark and knowing it will not run on starting fluid, that is really the only direction you would have to go anyway would be compression. The only other variable when you have spark and no start with starting fluid would be a -massive- blockage in the exhaust or something like that, however this would not cause the very significant compression loss you are seeing. Really to have a ~40% compression loss like that is really only going to be expected to be belt timing (be it the belt or a sheared cam gear locator pin etc). You could theoretically have valve damage, but that is far more often to show severe loss (0-50 psi readings) and inconsistent across cylinders. Showing low across all cylinders is just about always timing related or engine wear.... and if it were engine wear (rings), it would not happen all of a sudden, it would have been months/years leading up to this as power declined, so that is unlikely.If your compression readings are accurate, go back and double check your timing again as that is your biggest area of suspicion. Anything else like a blockage etc would be considered secondary concerns as long as your compression is that low.

Related Mitsubishi Questions