How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Doug Your Own Question
Doug
Doug, ASE Certified Technician
Category: Mitsubishi
Satisfied Customers: 6906
Experience:  Mitsubishi employed and Factory trained ASE certified technician
21364095
Type Your Mitsubishi Question Here...
Doug is online now
A new question is answered every 9 seconds

Mitsubishi Diamante LS: Changed valve cover gaskets and EVERYTHING

Customer Question

Changed valve cover gaskets and EVERYTHING else that was back there. Now it runs like crap!!!!!!! Why?
Submitted: 1 year ago.
Category: Mitsubishi
Expert:  Doug replied 1 year ago.
Hi,
Are you completely certain you have the plug wires ordered correctly?
How about the vacuum hoses? Specifically, is the hose off the rear valve cover attached to the intake duct or is it attached to the firewall pipe?
Customer: replied 1 year ago.
I hooked it back the way I took it off. What is the hose called for the two valve covers? Do u have a diagram for vacuum lines
Expert:  Doug replied 1 year ago.
The hose between the two valve covers is just a breather hose for the pcv. It can not cause the engine to run any differently at all.
My diagrams are more of a flow chart type that isn't too helpful for what you need; the diagram under your hood is more efficient.
Please verify you have your wires on the distributor correct and whether or not the hose on the rear valve cover is attached to the intake hose or the pipe to the firewall.
Customer: replied 1 year ago.
When I first cranked it run fine then it knocked a few times then stopped and then started again. Cut it off and went home. Went back next day took it all back apart and checked everything. Put it back together and same thing? The hose that runs from one valve cover to the next broke due to it being brittle so I replaced it with what I had laying around. It was a little to big but I put hose clamps on it.
Expert:  Doug replied 1 year ago.
Ok.