How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Cardoctor74 Your Own Question
Cardoctor74
Cardoctor74, ASE Certified Technician
Category: Mitsubishi
Satisfied Customers: 25950
Experience:  ASE Master Technician
3827149
Type Your Mitsubishi Question Here...
Cardoctor74 is online now
A new question is answered every 9 seconds

Mitsubishi Eclipse Spyder GS: i just did a full tune up on

Resolved Question:

i just did a full tune up on a eclipse gts 3.0 all wires and new plugs now it sounds like the exhaust is comming through the air filter like a backfire through the air filter i found that i did mis route wires fixed that now it only does it when stepping on gas and it runs ruff that way not at idal
Submitted: 5 years ago.
Category: Mitsubishi
Expert:  Greg replied 5 years ago.

Name is XXXXX XXXXX i will assist you the best i can, please Only accept if you are happy with my answer.

 

Did it have this issue before you did the tune up.

 

Is the check engine light on when the engine is running .

 

Regards Greg

Customer: replied 5 years ago.
the check engine light was on before the tune up for a o2 sensor and still on i was thinking of clearing the codes out and see if that changes it but dont think it will help it had a miss fire code also for cylinder 3 in the back i had to take intake off i replace valve cover gasket n plug hole gaskets witch was leaking oil i got everthing back the way it should be
Customer: replied 5 years ago.
Relist: Other.
cant wait time crunched need car to use for work
Customer: replied 5 years ago.
Relist: I still need help.
Expert:  Cardoctor74 replied 5 years ago.
Different expert here.When the car runs does it run rough at idle ?Were there any issues prior to the repair?
Customer: replied 5 years ago.
yes it had a misee fire code for cylinder three i just replaced the wires i bought with a new set thats better fitting now the car will not stay running im thinking the timming is off
Expert:  Cardoctor74 replied 5 years ago.
Does it run smooth and then stall out when letting off the gas?
Customer: replied 5 years ago.
it was running ok then it ran ruff and dont stay running at all now and cant get started
Expert:  Cardoctor74 replied 5 years ago.
Ok is it missing fuel or spark when not starting?
Customer: replied 5 years ago.
well when i step on gas it sputters out
Expert:  Cardoctor74 replied 5 years ago.
Ok has timing been checked along with fuel pressure/
Customer: replied 5 years ago.
no i didnt check that i dont have the tools for it and u have to take off intake to get to cylinder one to make sure its at top dead center right or is there another way it was running ok before i did the tune up but had a miss fire code when i took apart it had origanal plugs and wires in the back three i replaced cap rotor wires plugs and valve gaskets now its running bad i dont know if its something i did it looks that was i put everything back way it came off
Expert:  Cardoctor74 replied 5 years ago.
Ok is it possible you cracked a spark plug or the gap is not correct or the wires are in the wrong order?
Customer: replied 5 years ago.
i just check all plugs when i replaced all wires and made sure the order was right wires had numbers on them
Expert:  Cardoctor74 replied 5 years ago.
Ok were these cheap aftermarket wires ?
Customer: replied 5 years ago.
the first set was exact wires i replaced them with ngk more expensive wires
Expert:  Cardoctor74 replied 5 years ago.
Was this timing belt ever changed?
Customer: replied 5 years ago.
not that i know off i dont think it has beed the car has over hundred thousand on it but it ran good before this work now it dont is it cause maybe the shop before changed the timming to compinsate for missfire???
Expert:  Cardoctor74 replied 5 years ago.
Yes thats very very possible .I would check timing next.This link will help.
ClickHere
Hoped this helped.Positive feedback and bonuses greatly appreciated.
Customer: replied 5 years ago.
I had car to shop found that. I did nothing wrong that the cadilitic. Converter went bad at that time cause of all the miss fireing before the fix
Expert:  Cardoctor74 replied 5 years ago.
So the catalytic converter was is the cause they say?
Customer: replied 5 years ago.
Yea they removed it and its running fine
Expert:  Cardoctor74 replied 5 years ago.
Excellent glad it's fixed . Make sure you replace the timing belt before it snaps and damages the motor next .Glad it's fixed .
Customer: replied 5 years ago.
Thanks I would have never tried that as a mechanic myself wish I. Couldve figured that out n saved my customer the trip of towing car to a shop n paying big money to have them look at it makes me feel bad as a tech
Expert:  Cardoctor74 replied 5 years ago.
Happens . It's happend to me a few times over the 20 years I've been in the field. Sometimes we miss the obvious first but non the less no ones perfect. I've seen top techs spend weeks on an electrical issue and it turns out there was a blown fuse they missed something simple. So things happen . Just glad it's fixed.
Cardoctor74, ASE Certified Technician
Category: Mitsubishi
Satisfied Customers: 25950
Experience: ASE Master Technician
Cardoctor74 and 2 other Mitsubishi Specialists are ready to help you

Related Mitsubishi Questions