How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan
Dan, ASE Certified Technician
Category: Mercury
Satisfied Customers: 1655
Experience:  Auto Technician
94707146
Type Your Mercury Question Here...
Dan is online now
A new question is answered every 9 seconds

Well I was driving at about 55-60 mph when I first noticed

Customer Question

Well I was driving at about 55-60 mph when I first noticed the engine jump/ lurch; and I started slowing down even when pushing the gas pedal. A couple seconds after that the wrench symbol came on right before cut off and started shaking. After that I turned it off and restarted it after a couple minutes.
Submitted: 10 months ago.
Category: Mercury
Expert:  Dan replied 10 months ago.

Hello my name is***** am an ASE Master Technician and I am glad to help you out with your question.

Expert:  Dan replied 10 months ago.

If the wrench light came on it means there is going to be a code stored, we need the code to diagnose this. You could get a free scan at any auto parts store. Let me know what you come up with.

Customer: replied 10 months ago.
Thank you.... Well I was driving at about 55-60 mph when I first noticed the engine jump/ lurch; and I started slowing down even when pushing the gas pedal. A couple seconds after that the wrench symbol came on right before cut off and started shaking. After that I turned it off and restarted it after a couple minutes.
Expert:  Dan replied 10 months ago.

You could have a misfire causing the lack of power/ jump. This could be caused by a lot of different things, coil pack, vacuum leak, sensor problem. The first step is to get the codes.