How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask A. Penland Your Own Question
A. Penland
A. Penland, Ford Senior Master Technician, ASE
Category: Mercury
Satisfied Customers: 6212
Experience:  ASE Master Certified. ASE Gasoline Engine Performance Certified,Ford Senior Master Technician
14865528
Type Your Mercury Question Here...
A. Penland is online now
A new question is answered every 9 seconds

2008 mercury marquis? Have replaced compressor, evap. core,

Customer Question

2008 mercury marquis? Have replaced compressor, evap. core, orifice, and condenser? Flushed system till flush is clear? When evacuating air from system, system will only pull down half way? When trying to charge with Freon it will take one can and the low and high side gauges go crazy high? Confused. Acts as if it is stopped up but. I have replaced everything? Can u help? Replaced
drier also?
Submitted: 5 months ago.
Category: Mercury
Customer: replied 5 months ago.
has anyone tried to answer yet?
Expert:  A. Penland replied 5 months ago.

The system will not pull down to 30 inches of vacuum and hold for 30 minutes with the vacuum compressor off?

Customer: replied 5 months ago.
didn't ask that! It doesn't pull down for 30 seconds? Will not pull down but half that.
Customer: replied 5 months ago.
have tried 3 compressors and no results? All parts r new and it won't pull a vac. but it has no leak either.
Expert:  A. Penland replied 5 months ago.

Will the vacuum hold to where it stops with the AC machine off?

Customer: replied 5 months ago.
it holds it but it also will not accept but 12 ozs. of Freon and my gauges on the low and high side pegs out! I've never seen this before and it will not accept anymore freon
Expert:  A. Penland replied 5 months ago.

I did not read that you replaced the suction accumulator/receiver drier.

Customer: replied 5 months ago.
the high side gets so hot you can't touch the line?
Expert:  A. Penland replied 5 months ago.

Did you replace the suction accumulator/receiver drier?

Customer: replied 5 months ago.
I replaced the entire system
Customer: replied 5 months ago.
compressor 3 times and the drier twice
Expert:  A. Penland replied 5 months ago.

Sorry, please do not get upset. I cannot physically see your vehicle. Since it will not pull down into a full vacuum and will not fully charge, the system has a restriction in the system. A plugged line, orifice tube installed backwards, a plastic cap left on a line can all cause a restriction. You may need to disconnect each line and blow air through them to check and make sure they are clear, including the evaporator and condenser. Also inspect the orifice tube and make sure it was installed properly.

Customer: replied 5 months ago.
done it all! I'm not upset. Orifice in right and I have taken every piece off car and flushed and blown through. Just weird what is going on?
Expert:  A. Penland replied 5 months ago.

Make sure the AC machine is working properly. Disconnect the lines from the vehicle and see if it pulls the system into the proper vacuum of 30 inches.

Customer: replied 5 months ago.
got off machine! Have used 2 different sets of gauges and both do the same. Can't pull full vac. and can't put over one can of Freon in without it completely shutting down. weird!
Expert:  A. Penland replied 5 months ago.

Without physically seeing your Grand Marquis, your description is telling me that there is a restriction in the system.

Expert:  A. Penland replied 5 months ago.

You can also hook the AC machine up and disconnect one line from the AC compressor and see what side of the system and where the restriction is.

Customer: replied 5 months ago.
ok
Expert:  A. Penland replied 5 months ago.

ok.

Customer: replied 5 months ago.
hope this didn't cost me because I didn't get any help.........
Customer: replied 5 months ago.
I fixed the car!

Related Mercury Questions