How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dr.Carz Your Own Question
Dr.Carz
Dr.Carz, ASE Certified Technician
Category: Mercury
Satisfied Customers: 303
Experience:  10 year ford master tech last 3 yrs.with independant ase master certified
35496794
Type Your Mercury Question Here...
Dr.Carz is online now
A new question is answered every 9 seconds

My name is ***** ***** I have a 2006 mercury mountaineer the

Customer Question

Customer: hi my name is ***** ***** I have a 2006 mercury mountaineer the abs light, wrench and trac light come on - it is causing the abs system to kick in and I can't drive normally
JA: Thanks. Can you give me any more details about your issue?
Customer: this has only been happening when I drive in snow - if it's smooth surface - no problem (even though the abs light will stay on solid)
JA: OK got it. Last thing — JustAnswer charges a fee (generally around $18) to post your type of question to Mercury Experts (you only pay if satisfied). There are a couple customers ahead of you. Are you willing to wait a bit?
Customer: yes do I have time to grab a cup of coffee
JA: OK. Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Customer: did I give you enough info
Submitted: 11 months ago.
Category: Mercury
Customer: replied 11 months ago.
when I start the car: just the check engine and abs light stay on solid - when I start driving in the snow, the abs system kicks in and then the wrench and trac light come on and stay solid and then I can sort of drive normally through the snow - they remain on solid until I turn off the car.
Customer: replied 11 months ago.
when driving on smooth surfaces without snow (example a road with rain water), the abs and check engine light are still on and solid, but I don't feel the abs system kicking in like I do when driving in snow
Customer: replied 11 months ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Dr.Carz replied 11 months ago.

This can be an indicator of a broken tone ring or loose bearing. The abs/trac/advance trac system is design to work together in sync. If you have either fault listed above this will cause your concern. The system is in constant active/ready state I find it odd that with the lights on the advance trac would try to be active in snow conditions unless it see's the speed sensor inputs erratically. I would remove the abs fuse and have the truck scanned and system tested. way too expensive to guess, typical bearing replacement runs around 300 bucks(do not use a cheap bearing). How are your tires tread good and all the same size?

Expert:  Dr.Carz replied 11 months ago.

Any new info on the Mercury? Please remember to Rate my services and Accept Thank You.

Related Mercury Questions