How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan
Dan, Technician
Category: Mercury
Satisfied Customers: 23758
Experience:  Independent Shop Experience, 2 Year Automotive Diploma, & Access to Information Database
17871496
Type Your Mercury Question Here...
Dan is online now
A new question is answered every 9 seconds

My tail lights do not work on my 2007 montego

Customer Question

my tail lights do not work on my 2007 montego
Submitted: 1 year ago.
Category: Mercury
Expert:  Dan replied 1 year ago.

Do the brake light and signals work still? How about the license plate lights? Thanks.

Customer: replied 1 year ago.
brake lights work license plate no
Expert:  Dan replied 1 year ago.

Check fuse 8 of the Smart Junction Box (SJB) for a potential issue of not making solid contact in the fuse holder. If fuse 8 appears to show a good fit to the holder, inspect the Brown/White (BN/WH) wire's female terminal at pin 22 of the C2280e connector of the SJB to verify that the terminal and pin on the SJB are making solid mating contact. If the terminal of the connector also appears to be ok, run a replacement circuit from pin 22 of the C2280e connector to one of the rear tail/parking light socket assemblies to bypass a suspect wire issue in the harness. I'd also consider replacing the bulbs if you haven't already. Let me know how it goes or if you have more questions. Thanks.

Expert:  Dan replied 1 year ago.

The smart junction Box is what controls the lights. So problem is either SJB, wiring, or bulbs. Let me know if you have more questions, thanks.