How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Mercury
Satisfied Customers: 34443
Experience:  ASE Certs and Ford Certs
7276279
Type Your Mercury Question Here...
Ron is online now
A new question is answered every 9 seconds

My friend has a 1999 Mercury Villager and last night while

Customer Question

My friend has a 1999 Mercury Villager and last night while having a starting issue, some guy not only hooked up the jumper cables backwards but did this repeatedly and left them connected long enough for the jumper cables to stop working completely. Now I am tasked with figuring out what all got fried and I am a little overwhelmed. The ONLY electronic item that works is the headlights. Nothing else. am I looking at a new battery and ECU before i can go any further? I saw no burnt fuses or fusible links.
Submitted: 1 year ago.
Category: Mercury
Expert:  Ron replied 1 year ago.
Hello, my name is ***** ***** I am a professional here at Just Answer. I have noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
Start first with checking to see if all the fuse in the engine compartment fuse panel have power, this power comes from the two fuse link wire running from the battery. See the diagram in the link below, its common for theses links to blow if the system is jumped backwards.Check power at the under hood panel before you replace any thing and post back with the results .
https://dl.dropboxusercontent.com/u/104923897/Fuse%20panel%20Aug%2023.pdf

Related Mercury Questions