How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka- Moose) Your Own Question
Chris (aka- Moose)
Chris (aka- Moose), Mercury Technician
Category: Mercury
Satisfied Customers: 45061
Experience:  16 years experience with Mercury
2499435
Type Your Mercury Question Here...
Chris (aka- Moose) is online now
A new question is answered every 9 seconds

I have a 2000 grand marquis which I just replaced the intake

Customer Question

I have a 2000 grand marquis which I just replaced the intake manifold on. The car runs great but the ac clutch does not engage. As I was checking connections to make sure they were tight the clutch engaged and the ac worked fine so I shut it off and quit for the day thinking everything was ok but when I started it today the ac clutch would not engage! The connection that made it come on last night was at a part that was fastened to the firewall on the right side just above the heater hoses. What is your opinion of what is wrong and what is that part called?
Submitted: 1 year ago.
Category: Mercury
Expert:  Chris (aka- Moose) replied 1 year ago.

Any way I can get a picture of the part your referring to?

Are you good with doing some electrical diag?

If you jump power and ground to the compressor will it run and make cold air?

You want a excellent 5 star answer & I would like to be rated the same for providing it. Consider I don't know your skill level & I can't see, smell, hear, or touch the vehicle. It may take a few back and forth replies. Try your best to respond with good detail so I can do the same. I normally log in at 3pm and work late. A rating is required. Your rating me, what I type. I am not an employee of this website, nor have control over the fees or the time it took to get a response. If you rate negative or not at all you still paid, but I get nothing. I want you pleased with me and my efforts, so let me know if your experience here has come up short.

Thanks Chris

Customer: replied 1 year ago.
I fixed it yesterday, it was a bad connection
Expert:  Chris (aka- Moose) replied 1 year ago.

Glad you got it addressed, sorry you paid and resolved it on your own.

Related Mercury Questions