How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. master tech Your Own Question
Lou P. master tech
Lou P. master tech, Mercedes Technician
Category: Mercedes
Satisfied Customers: 4085
Experience:  15 years master certified 100% fix rate and have access to factory radio codes, wiring, and instructions.
27644750
Type Your Mercedes Question Here...
Lou P. master tech is online now
A new question is answered every 9 seconds

I have a sat radio in my gl450 that loses signal frequently

Customer Question

i have a sat radio in my gl450 that loses signal frequently do i possibly have an antenna problem
JA: Is this an aftermarket stereo, or did it come with the car?
Customer: came with car 2011 gl450
JA: What is the model of your '11 Mercedes?
Customer: suv gl450
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: had sirius send signal to reboot radio
JA: Anything else you want the mechanic to know before I connect you?
Customer: brake when depressed shudders like slipping no warning lights but i do see a yellow pyramid lighjt come on and blink
Submitted: 2 months ago.
Category: Mercedes
Expert:  Lou P. master tech replied 2 months ago.

Hello, my name is***** and i will do my best to assist you.I am going over your story now and will reply back soon with some info,thanks!

Expert:  Lou P. master tech replied 2 months ago.

your sat radio module in your model is very problematic, most likely the module needs replaced.

for the flashing warning, that is the traction system coming on, what are the condition of your tires?

the flashing occurs when the traction system is trying to stop the wheels from slipping, either you have a faulty wheel bearing with sensor or the tire tread is low and the wheels are slipping or there is a sensor fault, without a scan tool to detect what the module is seeing it can be hard to advise on what the issue can be specifically, sometimes only 1 wheel will chatter with the abs so it can be localized to a issue with the affected wheel. most times if its the wheel bearing you will have a slight humming noise when driving and turning. let me know if this helps, Lou P.

Please take a second and click the stars at the top of the screen to rate me so i may receive my credit , 5 stars is ideal , please request me in the future.
Keep in mind then when you rate it does not end our conversation. you can still return here to me for follow up information if needed, Lou P.

Customer: replied 2 months ago.
no humming sound as indicated by bad bearing and tires are six month old 2000 miles driven it must be a sensor fault. when i plugged in a module to identify errors it only shows a thermostate needs attention
Expert:  Lou P. master tech replied 2 months ago.

depending on the scan tool used you may only be reading the engine module, your car has 30 modules. not all scanners can read all codes. and also unless the triangle and esp lights are steady on the dash it will not be a stored fault, the car will think its operation is correct even though it is acting up.