How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, Mercedes Technician
Category: Mercedes
Satisfied Customers: 53776
Experience:  Bosch Certified Master Tech. Over 35 years experience.
13230946
Type Your Mercedes Question Here...
Marty is online now
A new question is answered every 9 seconds

Changed battery in SL600 1993 now nothing works, yes,

Customer Question

changed battery in SL600 1993 now nothing works
JA: Have you changed a battery before?
Customer: yes
JA: Are you fixing your SL600 yourself? What have you tried so far?
Customer: everything worked when I got it back from the Shop. I discovered the Neg cable wasn,t tight, removed to loosen bolt reinstalled on battery. now nothing works
JA: Anything else you want the mechanic to know before I connect you?
Customer: there was some clicking when I reinstalled the cable
Submitted: 4 months ago.
Category: Mercedes
Expert:  Marty replied 4 months ago.

Hi, my name is***** absolutely nothing in the car works, meaning there is no power anywhere in the car, the problem will have to be the battery or the battery cable connections.

Expert:  Marty replied 4 months ago.

You should recheck your cable connections. If you don't see anything wrong you can try connecting jumper cables from another battery and see if you get power. If you do it tells you that your battery is defective.

Expert:  Marty replied 4 months ago.

The only thing that can cause total loss of power to the car is the battery or the cable connections.

Expert:  Marty replied 4 months ago.

Just checking in. Did you get this figured out?