How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Mercedes Mechanic
Category: Mercedes
Satisfied Customers: 24657
Experience:  Over 15 years experience as a Mercedes dealer technician
14928985
Type Your Mercedes Question Here...
Pete is online now
A new question is answered every 9 seconds

A week ago the car was running and starting fine. I parked

Customer Question

A week ago the car was running and starting fine. I parked and when I came back to the car it would not start. I could move the shifter and some electric came on when I turned the key. Engine did no turn over at all, It sat for a week at my mechanics shop. One part of the right tail light stayed on and we could not shut it off. Today the mechanic was going to push it inside, but he could not get it off of park. A message said electrical system offline. It is a 2003 sl500.
JA: Have you checked the bulbs? Have you checked the connection?
Customer: What bulbs? What connection? How would those keep it from coming out of park?
JA: What is the model/year of your Mercedes?
Customer: 2003 sl500
JA: Are you fixing your SL500 yourself? What have you tried so far?
Customer: No. My regular local mechanic is doing it. He has not tried anything since he can't get it inside.
JA: Anything else you want the mechanic to know before I connect you?
Customer: No
Submitted: 11 days ago.
Category: Mercedes
Expert:  Pete replied 11 days ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

This model uses 2 batteries.One in the trunk for all electronics and one under the hood for the starter only.Has he checked the battery in the trunk to see if it is dead or weak at all?

Let me know so we can continue,thanks Pete.

Customer: replied 11 days ago.
They are dead (probably due to a tail light being on for over a week that we could not shut off) He briefly put a charger on it, but could still not get it out of park
Customer: replied 11 days ago.
No, I would like written answers
Customer: replied 11 days ago.
When can I expect a response?
Expert:  Pete replied 11 days ago.

No problem we can continue here.Looking at your info now on this and will respond shortly.

Expert:  Pete replied 11 days ago.

O.k.,the main battery in the trunk has to be charged to a point where there is a good charge of 12 volts or more before the electronics start to work which includes the shifter as this is released electronically.I would continue to charge the battery in the trunk and see if this then resolves the issue with not being able to remove from park.

If this works and the tail light issue is still ocurring, the tail light issue is usually due to a fault with a SAM control unit/ecu at fault needing replaced.I have seen the sam control units fail in the past before needing replaced for this fault here.

You would need to have the fault codes checked using a scan tool or dealers sds machine that will plug in and communicate with all computers in your model to see what codes are set in all computers.Once this is done this will help pinpoint if a sam is faulty needing replaced.The sam's can short out internally causing this issue.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 11 days ago.
I will take this answer to the mechanic and try it. I will have to log out. How do I get back to you if I have to log in again.
Expert:  Pete replied 11 days ago.

No problem

You can come back here to this post anytime before or after a rating is left.You can save the link to this post to your favorites to get back here or log back into the web site and look up your questions to access it.You can also get back here through your emails sent to you from this post.

Thanks Pete

Customer: replied 11 days ago.
That did not help getting the car out of park. My original problem was the car not starting under the circumstances I outlined in my first submission. Any ideas concerning that?
Expert:  Pete replied 9 days ago.

The car not starting can be related to the light staying on issue here and can still be a SAM at fault needing replaced.I have seen several failures of the SAM units in the past before causing a light to come on and in some cases causing a no start with the vehicle as well.If there is any way you can get the fault codes checked with a fully compatible scan tool that can read all computers in your vehicle this will help.If this is not an option let me know.

Let me know if you need anything else and feel free to rate my help here as this is how I receive credit for my time.Your 5 star rating is appreciated

Thanks Pete