How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, Mercedes Technician
Category: Mercedes
Satisfied Customers: 53153
Experience:  Bosch Certified Master Tech. Over 35 years experience.
13230946
Type Your Mercedes Question Here...
Marty is online now
A new question is answered every 9 seconds

I have a 1998 slk 230 i bought used and when i got it i had

Customer Question

Hey i have a 1998 slk 230 i bought used and when i got it i had to get a k40 relay that fixed it 8 months ago. I have had to use cheap gas afew times and it dont like it its supposed used 90 octane or better. Well its giving me a headache its wont accerlate unless its warmed up it takes ten to 15mins then it goes but slowly and if i push the gas pedal to much it stalls i let up alittle it goes well as the engines runs more and more it gets better after running it for a bout a hour or so its almost fixed then it starts again after it sits for about a hour. It idles fine. I have changed the plugs and wires and fuel filter it has good pressure what is wrong i dont get it. Oh as it acts up i put a code scanner on it no codes it used have misfire codes but not anymore
JA: Have you seen the misfire code before? Has the car been stalling?
Customer: Yes it use to be 1 and 4
JA: What is the model of your '98 Mercedes?
Customer: i bought both coils to
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: Slk 230
JA: Anything else you want the mechanic to know before I connect you?
Customer: I changed the catalic coverters to i have tryed all cleaners . It acts like its starving for fuel.
Submitted: 14 days ago.
Category: Mercedes
Customer: replied 14 days ago.
The super charger works fine.
What got it actin up was 87 octane gas but i added 93 to it before i needed gas the nexts day.
Expert:  Marty replied 13 days ago.

Hi, my name is***** any fault codes to go on it is difficult to say what may be the problem. Based on your description I would suggest you try a new mass air flow sensor. It sounds like you have a fuel pressure problem or a low fuel flow problem but if you say that the fuel pressure is correct (55 psi) I would try a new mass air flow sensor.