How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Mercedes Mechanic
Category: Mercedes
Satisfied Customers: 24697
Experience:  Over 15 years experience as a Mercedes dealer technician
14928985
Type Your Mercedes Question Here...
Pete is online now
A new question is answered every 9 seconds

I have a 2006 e500 that is doing the exact same thing that

Customer Question

I have a 2006 e500 that is doing the exact same thing that the other guy you were helping had. The only difference is before mine was cranking and driving just wouldnt come out of 1st or 2nd gear and then i killed it and it hasnt cranked in two weeks. I have replaced main battery and had auxillary battery tested. When you turn the key to crank it the dash displays several codes like low battery, abs, vehicle rising please wait but it doesnt rise, and it says visit workshop. I scanned the computers while it was still driveable and the code said something like turbine/input shaft speed sensor communication failure. But since then my code reader isnt working with vehicle when i try to pull a code. I bought the car used and i am afraid maybe it had gotten water in it before. Please help.
Thanks kenny
Submitted: 1 month ago.
Category: Mercedes
Expert:  Pete replied 1 month ago.

My name is ***** ***** I am a professional here at Just Answer. I noticed that your question had not received a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.

This sounds like a major loss of voltage or ground to electronics in the vehicle.If you know for sure the batteries are good I would check and see if there are any issues with the battery cables themselves at fault needing replaced.It is possible there is damage to one of the main battery cables needing replaced.If this is or was already checked with no success let me know.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Related Mercedes Questions