How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, Mercedes Technician
Category: Mercedes
Satisfied Customers: 53166
Experience:  Bosch Certified Master Tech. Over 35 years experience.
13230946
Type Your Mercedes Question Here...
Marty is online now
A new question is answered every 9 seconds

I replaced the battery on an 01 ml320 and it worked for a

Customer Question

I replaced the battery on an 01 ml320 and it worked for a week. Now it cranks when you turn the key, continues to crank after you release the key to the on position until you ultimately turn it off. never turns over
JA: Is the car in "Park" or "Neutral?" Do you know if your car has a "wheel lock" feature?
Customer: it is in park, not sure about wheel lock
JA: Are you fixing your ML320 yourself? What have you tried so far?
Customer: just battery. Now I'm wondering if a fuse blew and someone mentioned a solenoid, but there is something preventing it from turning over and it is very weird that it continues to try even when you release the key (not remove)
JA: Anything else you want the mechanic to know before I connect you?
Customer: that's it
Submitted: 1 month ago.
Category: Mercedes
Expert:  Marty replied 1 month ago.

Hi, welcome to Just Answer. My name is***** the ML, it is normal for the starter to continue to crank the motor after you release the key if the motor does not start. If you have a crank/no start condition you may have a bad crankshaft position sensor or a bad fuel pump. A test for spark and fuel pressure needs to be performed to see what you are lacking. You should check the fuses in the main fuse box under the hood to see if any have blown but more often than not this problem will come down to either a bad crank sensor or a bad fuel pump.

Let me know if you have any questions.

Marty