How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Marty Your Own Question
Marty
Marty, Mercedes Technician
Category: Mercedes
Satisfied Customers: 53602
Experience:  Bosch Certified Master Tech. Over 35 years experience.
13230946
Type Your Mercedes Question Here...
Marty is online now
A new question is answered every 9 seconds

I have a 1995 500SL. starts, runs 15 -20minutes, smells,

Customer Question

Hello, I have a 1995 500SL. starts, runs 15 -20minutes, smells rich, stalls, then pops and wont start. Replaced both the Cam and Crank sensors, Replaced the four fuses in the Base module. She wont run. Is there a way to test the Ignition Module where the sensors plug in. Oh and car has +- 200000 miles
Submitted: 5 months ago.
Category: Mercedes
Expert:  Marty replied 5 months ago.

Hi, my name is***** does not provide testing for the ignition module itself. Basically you just test for spark from the coils when the car won't start. If you have no spark then you make sure that the crank sensor signal to the module is good. Since you already replaced the crank sensor I would condemn the ignition module if you have no spark when it dies.

Customer: replied 5 months ago.
The question was not about the testing of the ignition module, the question is what could be my problem based on the information I gave you?
Expert:  Marty replied 5 months ago.

Sorry for the confusion. The first thing you need to do is test for spark from the coils when the car won't start. If you have no spark I'd condemn the module.

Expert:  Marty replied 5 months ago.

If you find that you have spark from the coils when it won't start I would inspect the caps and rotors for moisture and corrosion.

Customer: replied 5 months ago.
Can you tell me if I can us the Ignition Module from a 1997 S500? The one I have now is a###-##-####that someone else installed.
Expert:  Marty replied 5 months ago.

Do you have the part number of the one from the S500?

Customer: replied 5 months ago.
Sorry Marty I know you have good intentions. But I can go look tomorrow, my buddy has two of them. I thought you were specialized in these issues but I have found the same answers through on line research and I thought maybe you all would confirm my thoughts. This will conclude our time, thank you for your time.
Expert:  Marty replied 5 months ago.

I do specialize in Mercedes but without the part number I can't tell you whether it will interchange or not.