How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask MB Paul Your Own Question
MB Paul
MB Paul, Mercedes Technician
Category: Mercedes
Satisfied Customers: 3567
Experience:  Qualified Mercedes Benz Diagnostic Technician - 20+ years experience - Workshop Foreman for Mercedes
15777119
Type Your Mercedes Question Here...
MB Paul is online now
A new question is answered every 9 seconds

Ive got a 2003 sl500 and have replaced the ABC pump twice

Customer Question

Hello ive got a 2003 sl500 and have replaced the ABC pump twice now with no pressure at pressure valve at 0 psi. i assumed that the first pump was defective and ordered another. Still no pressure ,, what am i missing here it has always been pretty easy to replace. I cannot rodeo or anything. Tried to put 12v to pressure sensor at pump tried to pressurize the reservoir. Getting system pressure code immediately. Any Advise
Submitted: 2 months ago.
Category: Mercedes
Customer: replied 2 months ago.
Well i pressurized the reservoir one more time and pressure at 195psi. After i paid to get an answer from you. Oh well, thats Murphys Law! Thanks in advance guys looks like im okay
Expert:  Lou P. master tech replied 2 months ago.

Hello, my name is***** and i will do my best to assist you.I am going over your story now and will reply back soon with some info,thanks!

Expert:  Lou P. master tech replied 2 months ago.

Sorry I just came online and seen the question. Hope it is still working for you. Let me know if you still need assistance or not. Lou P.