How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask MB Paul Your Own Question
MB Paul
MB Paul, Mercedes Technician
Category: Mercedes
Satisfied Customers: 3567
Experience:  Qualified Mercedes Benz Diagnostic Technician - 20+ years experience - Workshop Foreman for Mercedes
15777119
Type Your Mercedes Question Here...
MB Paul is online now
A new question is answered every 9 seconds

No boost due to faulty egr according to Mercedes dealership

Customer Question

no boost due to faulty egr according to Mercedes dealership in Canada. Changed the egr, but no turbo yet. Also, the new egr was really sooted up after a couple of test miles.
JA: What year is your Turbo?
Customer: 03 2.7 sprinter
JA: Are you fixing your Turbo yourself? What have you tried so far?
Customer: we limped in from Canada to Arkansas. so far jus the egr and inspection.
JA: Anything else you want the mechanic to know before I connect you?
Customer: Just concerned about so much soot so fast. and of course the no boost.
Submitted: 5 months ago.
Category: Mercedes
Expert:  Lou P. master tech replied 5 months ago.

Hello, my name is***** and i will do my best to assist you.I am going over your story now and will reply back soon with some info,thanks!

Expert:  Lou P. master tech replied 5 months ago.

were there any fault codes or a check engine light?

Customer: replied 5 months ago.
Mercedes dealership said low boost code due to faulty egr. there were no engine lights or anything to indicate problem on the dash boards. the Mercedes dealership cleaned up the egr and my boost returned so I headed home. after about a thousand miles I lost it again, but made it home with very low pwr to climb hills etc on the interstated. ...starts and runs ok, but no power and black smoke when you go under any strain at all. will not downshift, so I do it manually, just to get going.
Expert:  Lou P. master tech replied 5 months ago.

ok, gotcha, so i will need the actual fault code number.

usually a issue with the diesels is a leak in the intake that makes the pressure sensors read incorrectly so it cuts out boost.