How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. master tech Your Own Question
Lou P. master tech
Lou P. master tech, Mercedes Technician
Category: Mercedes
Satisfied Customers: 3730
Experience:  15 years master certified 100% fix rate and have access to factory radio codes, wiring, and instructions.
27644750
Type Your Mercedes Question Here...
Lou P. master tech is online now
A new question is answered every 9 seconds

Ive got a 2006 c280 lux, getting power to gauges and ac only

Customer Question

Hi Ive got a 2006 c280 lux, getting power to gauges and ac only for a few sec intermittently, changed front and rear fuse box sams. here is a video of the action https://youtu.be/pNjWebWiG2g
Submitted: 3 months ago.
Category: Mercedes
Expert:  Lou P. master tech replied 3 months ago.

Hello. Tried the link it didn't work. Can you attach it again ?

Customer: replied 3 months ago.
youtu.be/pNjWebWiG2g
Customer: replied 3 months ago.
copy and paste that into a browser, should work ok.
Expert:  Lou P. master tech replied 3 months ago.
Ok that one worked. Thanks. So I think you may have a failing circuit 15 relay. I'll get you the location. I want you to swap the relay with another relay in a different position. See if that moves the problem elsewhere or doesn't change.
Expert:  Lou P. master tech replied 3 months ago.
Relay M is your "circuit 15" (key on power) relay. Swap that with a other that is identical. Make sure you mark it so we don't lose position ! I'll get you a diagram so you know which one it is. Also if you pick up the relay the letters are molded on the fuse box under the relay.
Expert:  Lou P. master tech replied 3 months ago.
https://www.mediafire.com/view/999m79f9h1ro4a7
Expert:  Lou P. master tech replied 3 months ago.
That is the fuse box in the engine bay on the drivers side.
Customer: replied 3 months ago.
Ok I will try it to swap it when I get home, but I've already swapped out the whole box with another that had all relays in it.
Customer: replied 3 months ago.
Could you get me a diagram where there is a good place to test that circuit inside the car?
Expert:  Lou P. master tech replied 3 months ago.
Ok so you didn't swap over all the fuses and relays you just replaced the whole fuse box with everything already installed ?
Expert:  Lou P. master tech replied 3 months ago.
If that's the case then we need to put a test light across terminals 85-86 where the relay goes into to see if the relay activation is kicking out. Also if you had a code reader to check for codes that would be great. It's possible the ignition switch is killing the signal to the Sam that is stopping activation of the relay.
Customer: replied 3 months ago.
I've replaced the front and rear fuseboxes with everything already installed in them, including relays and fuses. It didn't change the behaviour. I will scan for faults later tonight and update.
Expert:  Lou P. master tech replied 3 months ago.
Ok sounds good. Don't forget to the the test light test as I last described. If you don't know what I mean or haven't done things like this let me know ill explain.
Customer: replied 3 months ago.
When the key is in on position, I'm getting power at 85-86 on m relay. When the relay is out, it doesn't seem to change anything, what does it power?
Customer: replied 3 months ago.
The scanner I have is not seeing any faults, but the dash says esp is not available.
Expert:  Lou P. master tech replied 3 months ago.

ok, ,the scanner you have will only read emissions faults and engine codes, that relay powers the key on circuit, so it appears that your power in the car is good, its the communication system that has a failure, so you have 1 of 2 choices,

1- get a mercedes oem scanner or a icarsoft mercedes scanner from ebay that can read every module in the car,

2- take it to the dealer to get diagnosed.

the communication system runs between 15 modules in your car and narrowing down the issue will be near impossible without a fault code to go on . that is where we are at, i can certainly help but we have a roadblock at the moment. let me know how you would like to proceed. Please take a second and click the STARS above and rate my service 4 or 5 stars if you feel I have been helpful and please request me in the future. Keep in mind that when you rate it does not end our conversation, you can still return here to me for follow up information if needed, Thanks for choosing just answer. Also , if you feel i deserve one , BONUSES are GREATLY APPRECIATED! Thanks again , Lou P.

Expert:  Lou P. master tech replied 3 months ago.

I have taken my time to answer your question the best i could and i will continue to help if you need follow up information , all i ask is that you PLEASE take a second to rate my service so i may receive my credit for assisting you. Thank you.

Customer: replied 3 months ago.
I'll scan it with a full scan tool when I can make it to the shop. Just had a baby, so it might take me a few days.
Expert:  Lou P. master tech replied 3 months ago.

well CONGRATULATIONS!

take your time, i wanted to let you know i did not forget about you, i will be here when you are ready.

Customer: replied 3 months ago.
Hi, I didn't make it to a full scanner yet, but I've tried the torque app and it's getting me these faults. It seems like a common ground could be a culprit, do you have a diagram for the grounds I should check?
Expert:  Lou P. master tech replied 2 months ago.

ok all of those are engine codes, we need a better scanner to get the body codes as well, the codes will come from the front and rear sam and also hopefully the ac control unit.

Expert:  Lou P. master tech replied 2 months ago.

hope all is well with the little one, im here if you still need assistance.

Related Mercedes Questions