How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Matt Your Own Question
Matt, Engineer
Category: Mercedes
Satisfied Customers: 20361
Experience:  Mechanical Engineer with 23 years experience in the auto industry, 8 yrs in formula 1 engine testing
Type Your Mercedes Question Here...
Matt is online now
A new question is answered every 9 seconds

I have a 1983 300sd that starts and idles fine but it has no

Customer Question

I have a 1983 300sd that starts and idles fine but it has no power on take off with the accelerator to the floor. I have changed both fuel filters and have tried connecting the ip to a clean can of new diesel fuel and ensured no air was in the system. This just came on all at once.
Submitted: 1 month ago.
Category: Mercedes
Expert:  Matt replied 1 month ago.


check the connections to the EGR valve, if either the vacuum pipe of electrical connection are damaged / corroded then the EGR can be on all time which certainly will hurt performance. Its also possible that its a fault with the EGR valve so its worth removing the valve and cleaning it out with brake cleaner, if it looks particularly clogged then replace it.

If this is OK then check the small vacuum lines to the turbo and its connected control solenoid on the bulkhead, any cracks or leaks can give turbo issues and its best to have the boost pressure measured actually measured with a boost gauge to check that the turbo is healthy and that the sensor is reading correctly

If its a variable vane turbo (they’ll be an actuator on the turbo body - but not a wastegate) then check its vacuum pipework as above and check the connections to the diaphragm / solenoid valve

Also worth checking that the glow-plug relay is switching off as they can stick on and leave the glow plugs also on - on some cars this can force it into limp home

Also worth considering adding a bottle of injector cleaner into the tank as a clogged injector nozzle will reduce power and give poor combustion - the next stage on from this is to remove all the injectors and have them ultrasonically cleaned and flow checked

Also check all the high pressure hoses post turbo/s for any split hoses or cracked metal pipes, also check the ends of the intercooler as its not unheard of to pop the end caps off under high boost.

Expert:  Matt replied 1 month ago.


do you still need help?

Bear in mind that the site takes a deposit from you at the beginning and this is held by the site until you rate my answer at which point the cash is split between the site and the expert. I am only paid for my work on this question if you rate my answer, using the star system at the top of the screen. Please do not forget! Thank you