How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. master tech Your Own Question
Lou P. master tech
Lou P. master tech, Mercedes Technician
Category: Mercedes
Satisfied Customers: 3721
Experience:  15 years master certified 100% fix rate and have access to factory radio codes, wiring, and instructions.
27644750
Type Your Mercedes Question Here...
Lou P. master tech is online now
A new question is answered every 9 seconds

Lou, the Brake warning light came on today along with what

Customer Question

Hi Lou, the Brake warning light came on today along with what looks like another yellow brake symbol on the dash... when I pulled the error codes, the following were pending:
P0300 Multi Cylinder misfire
P0304 Cylinder 4 misfire
Are the warning lights and codes related? Whats the most likely causeof the misfire
Submitted: 3 months ago.
Category: Mercedes
Expert:  Lou P. master tech replied 3 months ago.

Hello again ! So what brake light is on ? The word "brake" , the (O) or the ESP/BAS?

Also for the misfire I want you to swap coil 4 with cylinder 1 and see if the misfit changed. Also leave the wires on the cylinders. Just swap the coils. If the misfire does move then the coil is the issue. If the misfire does not move then swap the wires. If it moves then the issue is the wires. If it doesn't move then swap the plugs. See what I am getting at ? Let's determine what it is by moving 1 part at a time and seeing if the misfire moved with it. Let me know. Lou.

Customer: replied 3 months ago.
I see, which is cylinder 4 also, the two lights are the Red "Brake" and the yellow (O)
Expert:  Lou P. master tech replied 3 months ago.
Ok cylinder 1-4 is passenger side. The cylinders are number in between the portions of the valve cover between the wires. Also the wires have a letter on them that match a letter on the valve cover they indicate where they are installed for the different lengths. Ok so the (0) is the brake pad wear sensor. So you want to check the brake pads on the passenger side I believe. They have the wear sensors installed. The sensor grounds at 3mm of pad life. And the brake light will come on as well in conjunction BUT also check the brake fluid level.
Customer: replied 3 months ago.
well that ended poorly, I dropped the coil from Cylinder 1and its toast. so the new question is, does the 2002 ML500 use the same coils as a 1999 ML430?
Customer: replied 3 months ago.
Also, the warning lights came on yesterday in the rain, but today they are off. I haven't had a chance to pull the wheels yet and look at the brakes. I was told the brakes were recently done, however I suspect they reused the sensors
Customer: replied 3 months ago.
well, good news, not only does the local Advance Auto have the replacement coil, when I went to remove the #4 Cylinder coil, the plug wire just dropped off, clearly not connected well. So I'll go check all of them and move on to the brake sensor lol
Expert:  Lou P. master tech replied 3 months ago.

all the coils are the same

Expert:  Lou P. master tech replied 3 months ago.

with the rain tells me that there is a leak somewhere possibly. that is not good if that happens again.

Expert:  Lou P. master tech replied 3 months ago.

ok gotcha , sorry i was going line by line and responding.

Customer: replied 3 months ago.
Cyl 4 coil
Customer: replied 3 months ago.
Wires look pretty bad
Customer: replied 3 months ago.
ok, I swapped the coils from #3 and #4 cylinders and no more codes so I am guessing the issue was the wire connections, but you can see that they are not in great shape. Also, several of the connectors leading from the harness to the coils have lost their retaining clips.. how is this remedied?
Customer: replied 3 months ago.
more about the leak? do you mean a brake system leak? or a faulty connection at the sensor that is affected by water?
Customer: replied 3 months ago.
Harness plugs
Expert:  Lou P. master tech replied 3 months ago.

You can get the clips from Benz. New connectors. Those wires do look horrible lol. As for the leak. Water leak not brake fluid leak. So yes faulty connection and water intrusion.

Expert:  Lou P. master tech replied 3 months ago.

I'll see about getting the plug connection part numbers.

Customer: replied 3 months ago.
ok, so for the brake sensors. I think they are passenger front and back only. Just pull the wheels and do an inspection? also, I'm going to queue up another question on the driver side door actuator ( I got the part)
Expert:  Lou P. master tech replied 3 months ago.

Yes for the brake sensors. What happens is they wear and ground to the rotor which will complete the circuit and set the light off. So of the sensor is not worn we have a wiring issue.

Customer: replied 3 months ago.
Well, the rotors have a significant lip and while the pads aren't terrible I suspect this is probably the second set of pads on one set of rotors
Customer: replied 3 months ago.
Passenger front rotor
Expert:  Lou P. master tech replied 3 months ago.

Could be. For sure. We never pad slap. We do pads and rotors. A little more cost each brake job but it stops the pads from brake fade.

Expert:  Lou P. master tech replied 3 months ago.

The minimum thickness is stamped on the outer edge of the "hat" of the rotor

Expert:  Lou P. master tech replied 3 months ago.

Judging by that lip you are probably right at minimum.

Customer: replied 3 months ago.
Sensor is maybe a little more than 1/16 from that lip
Expert:  Lou P. master tech replied 3 months ago.

Actually sensor is way further. Google the sensor you will see the nipple part that sticks in the pad. The part you see is not where the wire is at. Those pass look great. Make sure the white sensor lead is not running on the bracket that holds the pads from rattling.

Customer: replied 3 months ago.
Wire is good here but those rotors at 29mm
Customer: replied 3 months ago.
I see what u mean about the sensor
Customer: replied 3 months ago.
On a side note, these are two wire horns, the one on this side, one of the terminals just came right off when I touched it
Customer: replied 3 months ago.
How do I know if I have juice? And my apologies for jumping around
Expert:  Lou P. master tech replied 3 months ago.

no lol you are fine, sorry the horn has two terminals you are correct, power and ground, ground is always brown on our cars.

Expert:  Lou P. master tech replied 3 months ago.

you check for power when someone is pressing the horn pad(airbag)

Customer: replied 3 months ago.
Ok, so there is no obvious reason for the warning lights and they are off. It looks like the rotors are on their second set of pads in the front and its clear the rear has been completely replaced (properly) although the sensor is clearly aftermarket. The coupler is some translucent hard white plastic.I should probably replace all of the wires, and if I do that, I should hit the plugs too? the vehicle does have a very slight rough idle but no more misfire codes
Expert:  Lou P. master tech replied 3 months ago.

well, replacing the wires are your call, i know that ebay used to have a kit with all the wires at the correct length. if the brake lights are off then it most likley can be a water intrusion issue and having a code reader that can read mercedes may be what you need in the future. i have been looking more and more into the LAUNCH scan tools, like the diagin x431 and man they do everything. i have one on order now, the newest launch tool and will arrive anyday, i can let you know how it works if interested.

Customer: replied 3 months ago.
Well it looks like I'm going to have mercedes for a while so I'm definitely interested... I bet they are expensive :p
Expert:  Lou P. master tech replied 3 months ago.

no sir. under 500$

also there is a icarsoft brand under 200 for strictly mercedes

Customer: replied 3 months ago.
Oh wow, I am definitely interested. I am using a Alltech reader now
Expert:  Lou P. master tech replied 3 months ago.

gotcha.

Expert:  Lou P. master tech replied 3 months ago.

please do not forget to rate this chat and let me know if the issue comes back?