How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. master tech Your Own Question
Lou P. master tech
Lou P. master tech, Mercedes Technician
Category: Mercedes
Satisfied Customers: 4139
Experience:  15 years master certified 100% fix rate and have access to factory radio codes, wiring, and instructions.
27644750
Type Your Mercedes Question Here...
Lou P. master tech is online now
A new question is answered every 9 seconds

When i step on the gas its accelerates normally but when i

Customer Question

When i step on the gas its accelerates normally but when i let off gas and hit brakes a lght on the dash thats says ems comes on. There is a beep and the gas pedal is no longer functional until i restart engine. I was told gas pedal sensor. So i bought one and wonder how to instal
JA: Have you checked the fuses? The dashboard bulbs?
Customer: Yes all fuses are good. What do you mean dashboard bulbs?
JA: What is the model/year of your Mercedes?
Customer: 2001 e320 sedan
JA: Are you hoping to fix this yourself? What have you tried so far?
Customer: Well i would like to fix it. I have not tried anything but did buy the gas pedal sensor for $180
JA: Anything else you think the mechanic should know?
Customer: I just bought the car so im not to familiar with it yet.
Submitted: 8 months ago.
Category: Mercedes
Expert:  Lou P. master tech replied 8 months ago.

Hello, so sorry for the delay, are you still needing assistance?

Customer: replied 8 months ago.
very much
Customer: replied 8 months ago.
The small one i believe im going to check the other now
Customer: replied 8 months ago.
Excuse last text
Expert:  Lou P. master tech replied 8 months ago.

ok, what was the fault code you had? and the pedal sensor is located in the engine bay, it is a super easy install, it mounts to the bracket and plugs in, there really arent any work instructions for this that would explain better .

what was the fault code you had?

Customer: replied 8 months ago.
No fault code excep sos need worksop. Also brake wear. occasionally elec.stability malfunction
Customer: replied 8 months ago.
I bought the sensor but does not look the same as existing. I am wondering if it is something else causing it i just bought the car a week ago and the previous owner told me it was gas pedalsensor. He said it was under pedal so i think he doesnt really know. I will check fault codes again ae soon as my wife returns with keys in about a hour
Expert:  Lou P. master tech replied 8 months ago.

well i mean fault code with a scan tool hooked up to the obd2 port.

what is the part number you bought?

Expert:  Lou P. master tech replied 8 months ago.

your model the sensor is in the engine bay near the brake booster, the later models its part of the pedal.

Customer: replied 8 months ago.
It came from part store in a fed ex pack. The numbers. Are(###) ###-####Q04
Barcode
10.0980-0124.1
Barcode(###) ###-####
Customer: replied 8 months ago.
Expert:  Lou P. master tech replied 8 months ago.

ohhhhhhhhhhhhhhhhhhhh

that is an acceleration sensor for the traction system

Expert:  Lou P. master tech replied 8 months ago.

this is your sensor

Customer: replied 8 months ago.
The guy who sold me thecar said thats not the sensor he saidhereplaced it. What do you think it could be according to symptoms
Customer: replied 8 months ago.
Could it be the acceleration sensori i bought
Customer: replied 8 months ago.
Where is it located to instal
Expert:  Lou P. master tech replied 8 months ago.

EH , that is very hard to tell, normally an acceleration sensor like the one you have will not affect throttle. it only affects traction control. ESP, ABS. BAS, ASR.

the sensor is located under the center console, BUT i dont think that is even correct for your model, that is for a ML. is there a way you can get fault codes for me?