How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. master tech Your Own Question
Lou P. master tech
Lou P. master tech, Mercedes Technician
Category: Mercedes
Satisfied Customers: 3739
Experience:  15 years master certified 100% fix rate and have access to factory radio codes, wiring, and instructions.
27644750
Type Your Mercedes Question Here...
Lou P. master tech is online now
A new question is answered every 9 seconds

Master P is me again I need help I have this crossfire '04

Customer Question

Hi master P
is me again I need help
I have this crossfire '04
had a bad ECM
so I replaced with a used ECM along with key ignition cylinder immobilizer door lock cylinder and glove box key cylinder
and this thing fire right up no more cylinder 1 misfire everything work out fine
only thing CEL light is on so I tried to scan modules but just like with the old bad ECM
I have no communication with non of all modules
can you help me to find reason for no communication please Master thanks
Submitted: 4 months ago.
Category: Mercedes
Customer: replied 4 months ago.
Master never mind
I was able to communicate with ECM
And this is the only code coming in
See attachment
Expert:  Lou P. master tech replied 4 months ago.
Hey Byron so sorry for the delay. Was on baby duty overtime lol checking now.
Expert:  Lou P. master tech replied 4 months ago.
Code is for mass air obviously. But the code is saying that the sensor is unplugged like it cannot see the return voltage. So now we need to verify that the mass air flow is getting proper voltage and ground and signal return. Man I hope you do not have another bad ecm!!??
Customer: replied 4 months ago.
I also thought about that man and I hope it's not that because man that will definitely be very very very bad anyway look man the only way I was able to communicate with the computer was to go into a Mercedes Diagnostics I put a Mercedes in it and I was able to pull codes from the ECM
OK bud now now I have to look for 12 volts at red blue wire right
And ground wire is brown wire it should have ground full time right
Also brown and yellow wire is 5 volts reference
Which wire is the signal from the mas sensor to the ECM buddy
Expert:  Lou P. master tech replied 4 months ago.

MASS AIR FLOW SENSOR WIRES

  1. YELLOW W/ DARK GREEN TRACER IS INTAKE AIR TEMP SIGNAL
  2. RED W/ BLUE TRACER IS FUSED POWER INPUT
  3. BROWN IS GROUND
  4. BROWN W/ YELLOW TRACER IS 5V SUPPLY
  5. YELLOW W/ WHITE TRACER IS MAF SIGNAL

POWER AND GROUND SHOULD ONLY BE ACTIVE WITH KEY ON FROM WHAT I CAN SEE.

Customer: replied 4 months ago.
Thanks Master I will get back to it as soon I finish rebuilding this RE5RO5A nissan transmission
Expert:  Lou P. master tech replied 4 months ago.

You are a busy busy man Byron. I don't know how you do it :)

Customer: replied 4 months ago.
Trust me man I don't want to do this no more dude but right here where I live it's the only way to to survive
Take care of those little ones
Expert:  Lou P. master tech replied 4 months ago.

yeah man i hear you , you too

Expert:  Lou P. master tech replied 3 months ago.

any luck? or busy still :)

just checking on you.

Customer: replied 3 months ago.
Thanks Master I will get back to you I haven't get to it yet
Expert:  Lou P. master tech replied 3 months ago.

ok good deal, have a good weekend and a good cerveza :)

Customer: replied 3 months ago.
Master
I have 12 volts on red/blue or blue/Red wire with key on and ground on brown wire
Expert:  Lou P. master tech replied 3 months ago.

byron, you replaced the ecm because of why? i forgot?

Customer: replied 3 months ago.
Injector one was open full time
But I was never able to see codes from it
So I assume code was there to and I may have a bad mass sensor
Expert:  Lou P. master tech replied 3 months ago.

ok that is right, so plug the old one back in if you still have it (module), the car will not start obviously but you should still be able to confirm the codes get erased for the mass air flow.

Customer: replied 3 months ago.
You are it bud
Why didn't I think of it
That's why you are the Grand Master Pete
I will check it out let you know ok
Expert:  Lou P. master tech replied 3 months ago.

OK LOL