How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Lou P. master tech Your Own Question
Lou P. master tech
Lou P. master tech, Mercedes Technician
Category: Mercedes
Satisfied Customers: 3720
Experience:  15 years master certified 100% fix rate and have access to factory radio codes, wiring, and instructions.
27644750
Type Your Mercedes Question Here...
Lou P. master tech is online now
A new question is answered every 9 seconds

I have a No Satellite Radio message on my GL450. I opened

Customer Question

Michael I have a No Satellite Radio message on my GL450. I opened the driver door and disconnected the beg bat under passenger seat for a few min. No joy. Any suggestions?
Submitted: 4 months ago.
Category: Mercedes
Customer: replied 4 months ago.
I disconnected the Neg battery terminal. Didn't work. 2007 gl450. My email is***@******.***
Customer: replied 4 months ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  Lou P. master tech replied 4 months ago.

Hello, with the battery connected, i need you to unplug and reconnect the sat radio module located under the drivers back seat bottom. here is a link.

then the system should start up, if not you need a new sat radio module. hope this helps, let me know if this helps or not please, i am here to help. Lou P.

Customer: replied 4 months ago.
Thank you for the suggestion. I disconnected the sat module but not the blue antenna connector. Same error message appears. Before I order a module, could it be a faulty antenna wire?
Expert:  Lou P. master tech replied 4 months ago.

ok so the issue is going to be the module, the antenna will not affect the operations only the sound quality. when the message NO SAT RADIO comes on the screen that means that the system cannot recognize the module. the only last thing you can check is the fuse, ill get you the location.

Customer: replied 4 months ago.
Location of sat mod fuse?
Expert:  Lou P. master tech replied 4 months ago.

39 in the rear trunk fuse box on the right side of the cargo area

Customer: replied 4 months ago.
Fuse 39 7.5 amp is good. I'll install a new Sat Module and let you know how it goes.
Expert:  Lou P. master tech replied 4 months ago.

ok, another test is to have the radio off, unplug the fiber optic line to the sat module, turn the radio on, the red light should flash a few times out of the lines on one end only and the sat radio module will flash out of a port as well, if no flash then another nail in the coffin.

Expert:  Lou P. master tech replied 4 months ago.

each time the radio is turned on the fiber optic lines will be pulsed to check communications. there is one line in and one line out, so the line that pulsed TO the sat module is the input and then the sat module will pulse on the opposite side , if that makes sense. if no pulse of red light, boom, dead. just make sure that the wiring is still connected to the sat radio module, just remove the fiber optic orange lines. Please take a second and click the stars at the top of the screen to rate me so i may receive my credit , 5 stars is ideal , please request me in the future.
Keep in mind then when you rate it does not end our conversation. you can still return here to me for follow up information if needed, Lou P.

Customer: replied 4 months ago.
Lou,
I installed a new Sat Radio module and it still doesn't work. What does that mean?
Expert:  Lou P. master tech replied 4 months ago.

With the new one let's check to see if we are getting a red pulse out of it.

Customer: replied 4 months ago.
Can I pull the fiber optic lines from the connector housing without ruining the integrity?
Expert:  Lou P. master tech replied 4 months ago.

The fiber optic lines should both be in a small connector that can all come out of the bigger connector. If I remember correctly the plug should have the fiber optics and the wiring for the module all in one.

Expert:  Lou P. master tech replied 4 months ago.

And yes. As long as you do not kink them they will be fine

Customer: replied 4 months ago.
Just ran the test with the old unit and new unit. On both units I got no red flash from the removed fiber optic cables and got two one second flashes from both units from the unit.
Expert:  Lou P. master tech replied 4 months ago.

ok , well that means that the sat radio is ok.......

and the issue is somewhere else. so we need to access the cd changer and the amp under the seat.

Customer: replied 4 months ago.
Ok I'll need you to step me through that tommorrow. I hope it's a loose fiber optic connector at the other end. I had this problem for a week 6 mos ago and it fixed itself.
Expert:  Lou P. master tech replied 4 months ago.

ok so are you near the car now? we can try to pull the fuse to see if it resets, the same as disconnecting without all the hard work. also did it rain or the car get wet before this?

Customer: replied 4 months ago.
No it hasn't rained. Can you call me at(###) ###-####
Customer: replied 4 months ago.
I'm near the car
Expert:  Lou P. master tech replied 4 months ago.

cant call without doing a phone offer, sorry, also i would hate for you to call me right now and have to wait for me to locate the fuses. so lets hang on to that thought until we need to.

Customer: replied 4 months ago.
Tell me what fuse to pull and I'll try that.
Expert:  Lou P. master tech replied 4 months ago.

so far fuse 35 in the rear trunk fuse box.

Expert:  Lou P. master tech replied 4 months ago.

then fuse 14 in the passenger side of dash fuse box. that first fuse is for the amp the second is for the cd changer

Customer: replied 4 months ago.
Lou, I haven't been able to work on the car for a few days. I checked fuse 14 in the glovebox. It is not blown. Where do we go from here?
Customer: replied 4 months ago.
Also fuse 35 is good.
Expert:  Lou P. master tech replied 4 months ago.

ok did the radio system come back to life at all after removing the fuses?

Customer: replied 4 months ago.
I took 35 out and reinstalled it last week and drove the car. I pulled 14 today and started the car just now and after the "Aquire satellite" finished I got the "no satellite radio"message.
Expert:  Lou P. master tech replied 4 months ago.

ok, so that is good and bad, if the acquire sat came on that means that the sat radio module was working, but then the fiber optic system went down again so if you are still going to attempt to fix yourself then it is going to take a good amount of time at one time to access all the audio equipment, disconnect the connections and watch for the red fiber optic, the other option is to just go ahead and get the codes read and see if that tells the issue off the bat , i dont mind helping either way it will just speed up the process on both of our ends .

Related Mercedes Questions